WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Page Cache - Status = not cached? (48 posts)

  1. robnalexpress
    Member
    Posted 2 years ago #

    Welcome to the club! I've submitted a but report and hope you and everyone experiencing this will too. Hopefully Frederick can get it fixed soon in the development version. It's troubling that he says it's fixed when clearly it's not.

  2. CyberOto
    Member
    Posted 2 years ago #

    @robnalexpress Can you provide your link for the report ?

    As more tests have been done, the bottom line is - W3TC is creating cached copy on every refresh of one and the same page.

    I hope this is fixed soon, as it seems the check for cache age is a bit off.

    Regards,

    P.S.
    Already got an e-mail for one hosting account taking too much CPU resources on shared hosting ... I do not like the VPS alternative and I have taken steps to have working plugin for cache.

  3. robnalexpress
    Member
    Posted 2 years ago #

    @CyberOto- Submit the bug report from the w3tc support tab: http://yoursite.com/wp-admin/admin.php?page=w3tc_support

    I'll check my resource usage as well. Only one of my sites is on a shared host and it's just a goof-off/test site. The other 2 are multisite on VPS at liquidweb (which I highly recommend).

    Monthly bandwidth on my little shared, low traffic site averages around 1.20 Gig per month. Don't see any particular spike.

    The multisite is usually 40-50 Gig, up to 66.78 for August. Not seeing any particular usage spike.

  4. CyberOto
    Member
    Posted 2 years ago #

    Thanks, I have totally forgot about this link =[

    Will check the offers on liquidweb dot com.

    Regards,

  5. robnalexpress
    Member
    Posted 2 years ago #

    This is apparently not a new issue- was being discussed here a month ago.

  6. joem5656
    Member
    Posted 2 years ago #

    But the upgrade to 094 caused this problem for many people, including me -- cached files being created but not served. And potentially being created on each page load, though not everyone seems to have that symptom.

    I'm sure Frederick will be in with an update before too long.

  7. robnalexpress
    Member
    Posted 2 years ago #

    A poster from that other thread writes:

    I contacted my hosting provider (Rackspace Cloud Sites), and they show that the pages are indeed pulling from the cache files. However, they weren't able to determine why the cache files are being recreated for every page view.
    So who knows if cached pages are being served or not....

  8. joem5656
    Member
    Posted 2 years ago #

    If cache is being rewritten for every page view, that as non-performant as no caching at all, obviously.

  9. robnalexpress
    Member
    Posted 2 years ago #

    True dat.

  10. kmccarth
    Member
    Posted 2 years ago #

    I'm seeing a similar problem with 0.9.4: cached pages being created in opcode but not being served. I have contact Frederick via my support tab but have yet to hear back (I'm sure he is quite busy). Anyone out there figure out how to serve the cached pages?

  11. johnny_n
    Member
    Posted 2 years ago #

    Looks like I'm having the same problem... everything was set and configured 2 months ago, and I didn't really check to make sure everything was still working after this latest upgrade.

    I've now disabled all but minify and cdn (i.e. all caching) and I'm seeing a very noticeable performance increase (compared to what was working before upgrade).

    Something isn't right with 0.9.2.4...

  12. savvyharry
    Member
    Posted 2 years ago #

    switching over to memcached for now and it shows cache is serving...

    the bug is definitely with disk enhanced.

  13. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    This will be simplified in the next release.

  14. ibtyrone
    Member
    Posted 2 years ago #

    I got mines to work by unchecking:
    - Cache requests only for [HOSTNAME]

    In Performance > Page Cache

  15. dsyd
    Member
    Posted 2 years ago #

    This fixed it for me:

    In .htaccess, I replaced...

    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
        RewriteRule ^(.*\/)?w3tc_rewrite_test$ $1?w3tc_rewrite_test=1 [L]
        RewriteCond %{HTTP:Accept-Encoding} gzip
        RewriteRule .* - [E=W3TC_ENC:_gzip]
        RewriteCond %{REQUEST_METHOD} !=POST
        RewriteCond %{QUERY_STRING} =""
        RewriteCond %{REQUEST_URI} \/$ [OR]
        RewriteCond %{REQUEST_URI} (sitemap(_index)?\.xml(\.gz)?|[a-z0-9_\-]+-sitemap([0-9]+)?\.xml(\.gz)?) [NC]
        RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-(app|cron|login|register|mail)\.php|\/feed\/|wp-.*\.php|index\.php) [NC,OR]
        RewriteCond %{REQUEST_URI} (wp\-comments\-popup\.php|wp\-links\-opml\.php|wp\-locations\.php) [NC]
        RewriteCond %{HTTP_COOKIE} !(comment_author|wp\-postpass|wordpress_\[a\-f0\-9\]\+|wordpress_logged_in) [NC]
        RewriteCond %{HTTP_USER_AGENT} !(W3\ Total\ Cache/0\.9\.2\.4) [NC]
        RewriteCond "%{DOCUMENT_ROOT}/wordpress/wp-content/w3tc/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" -f
        RewriteRule .* "/wordpress/wp-content/w3tc/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [L]
    </IfModule>
    # END W3TC Page Cache core

    with...

    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
        RewriteRule ^(.*\/)?w3tc_rewrite_test$ $1?w3tc_rewrite_test=1 [L]
        #RewriteCond %{HTTP:Accept-Encoding} gzip
        #RewriteRule .* - [E=W3TC_ENC:_gzip]
        RewriteCond %{REQUEST_METHOD} !=POST
        RewriteCond %{QUERY_STRING} =""
        RewriteCond %{REQUEST_URI} \/$ [OR]
        RewriteCond %{REQUEST_URI} (sitemap(_index)?\.xml(\.gz)?|[a-z0-9_\-]+-sitemap([0-9]+)?\.xml(\.gz)?) [NC]
        RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-(app|cron|login|register|mail)\.php|\/feed\/|wp-.*\.php|index\.php) [NC,OR]
        RewriteCond %{REQUEST_URI} (wp\-comments\-popup\.php|wp\-links\-opml\.php|wp\-locations\.php) [NC]
        RewriteCond %{HTTP_COOKIE} !(comment_author|wp\-postpass|wordpress_\[a\-f0\-9\]\+|wordpress_logged_in) [NC]
        RewriteCond %{HTTP_USER_AGENT} !(W3\ Total\ Cache/0\.9\.2\.4) [NC]
        RewriteCond "%{DOCUMENT_ROOT}/wordpress/wp-content/w3tc/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" -f
        RewriteRule .* "/wordpress/wp-content/w3tc/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [L]
    </IfModule>
    # END W3TC Page Cache core

    I think this means that my cached pages aren't being gzipped, but at least now they are actually being cached and not regenerated each time.

    Uncommenting these two lines, I get the "status: not cached" problem again:

    #RewriteCond %{HTTP:Accept-Encoding} gzip
        #RewriteRule .* - [E=W3TC_ENC:_gzip]
  16. haddow777
    Member
    Posted 2 years ago #

    I have not had an issue with gzip, but I have run into this problem several times. Here is what I have concluded from running into it several times.

    If you have any debug output on, it will cancel the cache. Page caching is meant to circumvent PHP, but wanting debug info generated forces W3TC to skip the cached file and load PHP. I know it is counter-intuitive, but it makes sense. First step, turn off all debug output. If you want to check to see if your files are caching, check the pgcache directory for newly generated files and your load times using a tool like Chrome's developer tools network tab.

    Also, most default setups of W3TC prevent caching for logged in users. Make sure you are logged out. I have had trouble even logged out though. I'm not sure why, but even after I logged out in chrome, the files still wouldn't cache. When I loaded Firefox, a browser I hadn't logged in with before, the pages started caching.

  17. Zeokat
    Member
    Posted 2 years ago #

    If you turn off "debug" how you know if the page is being cached? has no sense haddow777. Because cache files can be created but perhaps not served correctly.

    The bad part is that the author not add any fix to this issues.
    And i read in one post by the author if the pligin says "not cached" the page served is NOT cached.

  18. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Again the next version avoids false positives. Either way, the HTML comment in the source code will have a new date / time if the page is not sent from cache.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic