WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Page Cache - Status = not cached? (48 posts)

  1. lsatdown
    Member
    Posted 3 years ago #

    Have the latest version installed, logged out of wordpress with debug more turned on. Still status = not cached??

    Engine: disk (enhanced)
    Cache key: issue/the-tailored-issue/_index.html.gzip
    Caching: enabled
    Status: not cached
    Creation Time: 1.117s
    Header info:
    X-Pingback: http://dev.fashion156.com/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Content-Type: text/html; charset=UTF-8
    Last-Modified: Mon, 15 Aug 2011 18:34:11 GMT
    Vary: Accept-Encoding, Cookie
    X-Powered-By: W3 Total Cache/0.9.2.3
    Content-Encoding: gzip

    The same output (not cached) on all pages / posts

  2. cozmic_
    Member
    Posted 3 years ago #

    Same problem for me.i sent a bug report to Frederick Townes. i have been waiting for 2 weeks but he hasn't replied me yet :(

  3. boogah
    Member
    Posted 3 years ago #

    Yep. I've seen customers and clients running into the same thing.

    Sometimes I can get it to show cached content when I clear out my cookies, but other times I've seen the same message in view source across different browsers on the same computer. Like ones I've never even logged into WordPress from.

    I'll be interested to see if/when there's a fix for this, but I've been recommending Super Cache in the interim.

  4. lsatdown
    Member
    Posted 3 years ago #

    Hmm thats anoying! Guess I shall have to use super cache.
    Thanks for the advice

  5. squaretwo
    Member
    Posted 3 years ago #

    Same issue. The cache directory has seen the items generated. I wonder if this is a false message?

  6. cozmic_
    Member
    Posted 3 years ago #

    Installing supercache instead of w3t can solve only page caching problem. But w3t support all caching types. So we need to solve this serious issue.
    @squaretwo this is not a false message. i have already tested it by installing a random posts plugin. After each refresh of the page random posts sequence has been changed. it is proof that the page caching of w3t doesn't work!

  7. CyberOto
    Member
    Posted 3 years ago #

    Got the same issue. Partially fixed it by adding trailing slash to the perma links structure.

    Now I have some of mine pages cached, but not all. Weird.

    Regards,

  8. CyberOto
    Member
    Posted 3 years ago #

    Happy face. Have some news.

    Found the bugger that was messing with W3TC proper working (in my case). One plugin have this line '@ob_start("ob_gzhandler");' and after commenting it the W3TC start to cache all pages.

    It worked in my case, please check and see if there is something similar that is trying to do GZIP compression for the HTML and share you findings.

    Regards,

  9. squaretwo
    Member
    Posted 2 years ago #

    Good find CyberOto!
    Which plugin is this? I shall do a grab soon.

  10. joem5656
    Member
    Posted 2 years ago #

    Anything further on this?

  11. robnalexpress
    Member
    Posted 2 years ago #

    In this closed thread, Frederick states:

    "You can always look on the file system or in the opcode cache control panel to see if objects are being created."

    Can someone explain this? I'm getting "not cached" status on all pages, posts and index on 3 sites. Would love to know if there's another way to see if pages are being cached or not.

  12. Galerio
    Member
    Posted 2 years ago #

  13. robnalexpress
    Member
    Posted 2 years ago #

    I submitted a bug report recently. I see Frederick is doing one of his posting marathons- hope he'll reply and shed some light on this.

  14. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    This is fixed in the development version. Sorry for the trouble.

  15. robnalexpress
    Member
    Posted 2 years ago #

    Thanks, Frederick. What is the best way to install the development version? Uninstall current version, install development version, upload settings?

  16. robnalexpress
    Member
    Posted 2 years ago #

    This is fixed in the development version. Sorry for the trouble.

    No, it's not. Just installed development version 0.9.2.5b, and still getting:

    <!-- W3 Total Cache: Page cache debug info:
    
    Engine:             disk: enhanced
    
    Cache key:          _index.html_gzip
    
    Caching:            enabled
    
    Status:             not cached
    
    Creation Time:      0.323s
    
    Header info:
    
    Set-Cookie:         bb2_screener_=1315863307+108.66.209.1; path=/
    
    X-Pingback:         http://mysite.com/xmlrpc.php
    
    Content-Type:       text/html; charset=UTF-8
    
    Last-Modified:      Mon, 12 Sep 2011 21:35:07 GMT
    
    Vary:               Accept-Encoding, Cookie
    
    Expires:            Mon, 12 Sep 2011 21:38:07 GMT
    
    Pragma:             public
    
    Cache-Control:      public, must-revalidate, proxy-revalidate
    
    Etag:               02bf4a699f1153dcf306c56cd1e02303
    
    X-Powered-By:       W3 Total Cache/0.9.2.5b
    
    Conte
  17. bt-chadski
    Member
    Posted 2 years ago #

    Have you tried to re-enable the plugin? Re-save settings? Reset all caches?

  18. robnalexpress
    Member
    Posted 2 years ago #

    Yes, yes and yes.

  19. bt-chadski
    Member
    Posted 2 years ago #

    @robnalexpress,

    this is the extent of my technical and troubleshooting skills. =(

  20. CyberOto
    Member
    Posted 2 years ago #

    Morning all,

    Have you checked my finding about @ob_start("ob_gzhandler"); problem I had?

    If you do not have exact same code, you can check for similar code for compression - just do a full search in your plugins or theme files.

    Hope that you will find find your buggers, as I found mine.

    Regards,

  21. jorgitobg
    Member
    Posted 2 years ago #

    Hi,

    Im having many problems... pages not caching, minify not working, etc... etc.... my first byte received takes more than 7 seconds!!!

    While all this problems are fixed im using wp-super cache and now my site answers pretty fast again!.

    It is normal that a mayor update has all this bugs???

    Regards,
    [sig moderated as per the Forum Rules]

  22. Galerio
    Member
    Posted 2 years ago #

    Have you checked my finding about @ob_start("ob_gzhandler"); problem I had?

    If you do not have exact same code, you can check for similar code for compression - just do a full search in your plugins or theme files.

    I have tryed to disable all plugins but W3TC and my theme doesn't have any gz compression or other method.

    This problem is on all my 5 blogs that use different theme and different plugin and 3 of them are on 3 different servers.

    I can confirm that also developer version 0.9.2.5b doesn't fix the problem.

  23. robnalexpress
    Member
    Posted 2 years ago #

    This thread is starting to become diluted. OP has nothing to do with gzip, minify or other plugins. Let's stay on track with the issue of page status: not cached in debug mode.

    One plugin have this line '@ob_start("ob_gzhandler");' and after commenting it the W3TC start to cache all pages.

    When you say "W3TC start to cache all pages" how do you know this? Do you mean it's creating the files in the page cache directory? For me, the page cache files are being created, but in debug mode, using various settings and cache cleared browsers, I'm still seeing "status: not cached".

    So the question is: Is W3TC serving cached pages or not?

  24. CyberOto
    Member
    Posted 2 years ago #

    When you say "W3TC start to cache all pages" how do you know this? Do you mean it's creating the files in the page cache directory? For me, the page cache files are being created, but in debug mode, using various settings and cache cleared browsers, I'm still seeing "status: not cached".

    So the question is: Is W3TC serving cached pages or not?

    Hi,

    After commenting that line, W3TC started to create files and in debug mode all is fine too.

    Bottom line - W3TC started to serve cached pages.

    Regards,

  25. robnalexpress
    Member
    Posted 2 years ago #

    @CyberOto- Lucky you! I searched my folders for variations on @ob_start("ob_gzhandler"); and found nothing.

  26. Galerio
    Member
    Posted 2 years ago #

    @robnalexpress the problem is that cached pages that you can see in cache folder are only "non compressed pages". This is the problem, the plugin sould create beside the uncompressed pages, also a compressed gz one! But this gzipped file isn't there.

    Look here for a complete explanation:
    http://wordpress.org/support/topic/bug-disk-enhanced-cache-doesnt-work-in-0924

    Check it out and the report to Frederick Townes

  27. robnalexpress
    Member
    Posted 2 years ago #

    @galerio- I have the following files for every page & post:

    _.index.html and _.index.html_gzip

  28. robnalexpress
    Member
    Posted 2 years ago #

    Since the files are being created, in my case, I'd love to know if the "status: not cached" is a false indicator. Is there another tool, other than the W3TC debug, that I can use to determine this?

  29. CyberOto
    Member
    Posted 2 years ago #

    I spoke too soon =[

    Just upgraded *all* my sites to 0.9.2.4 and got this:

    <!-- W3 Total Cache: Page cache debug info:
    Engine:             disk: enhanced
    Cache key:          _index.html_gzip
    Caching:            enabled
    Status:             not cached
    Creation Time:      1.088s
    Header info:
    X-Pingback:         http://somedomain.com/xmlrpc.php
    Content-Type:       text/html; charset=UTF-8
    Last-Modified:      Wed, 14 Sep 2011 12:11:44 GMT
    Vary:               Accept-Encoding, Cookie
    Expires:            Wed, 14 Sep 2011 20:11:44 GMT
    Pragma:             public
    Cache-Control:      max-age=28800, public, must-revalidate, proxy-revalidate
    Etag:               196379ba76593e7c9bb9fb0d9cd96174
    X-Powered-By:       W3 Total Cache/0.9.2.4
    Content-Encoding:   gzip
    -->

    Have no fear, told to myself, 0.9.2.3 is working fine. Next step was to downgrade and enable the 0.9.2.3.

    Tadaaa ... NOT

    Now 0.9.2.3 is not working too. ARGHH!

    Back to square one.

    Regards,

  30. CyberOto
    Member
    Posted 2 years ago #

    Ad another observation with 0.9.2.4

    Each time visitor load a page, the cached file for this page is regenerated. So, it is creating the files, but not using them, as they are re-created on each visit. A side effect of that is server load...

    Regards,

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic