WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
page cache disk enhanced - Â characters appear (44 posts)

  1. mbrsolution
    Member
    Posted 1 year ago #

    Hello all, do you know if this issue is resolved with the current update 0.9.2.9?

    Kind regards

  2. Mike McKoy
    Member
    Posted 1 year ago #

    This is a bigger problem than I thought. It happens in basic mode to and our site is being slowly delisted from search results.

    WTH? Why hasn't the author acknowledged this? Traffic is falling and we cannot operate without a page cache.

    This plugin is broken for everyone using basic file cache or advanced file cache. Because that happens on shared hosting this plugin is broken for most of the users.

    INSANE!

  3. Nic Windley
    Member
    Posted 1 year ago #

    Try adding this (below) to your top level (root) htaccess

    AddDefaultCharset utf-8

    Rules were still getting replaced by W3TC for me so not always reliable.
    I fixed it with a permanent rule.

  4. Mike McKoy
    Member
    Posted 1 year ago #

    That didn't work. We're still getting errors. I've been told to remove W3tc and replace with WP-Supercache which works fine. The author had two months to address this and didn't.

    Thats not good at all.

  5. Nic Windley
    Member
    Posted 1 year ago #

    Firstly remember that its free - although I agree the troubles with caching plugins are frustating especially as they are becoming so essential.

    Secondly it could be a server config issue so make sure you've checked all those things that could cause an encoding error.

    Also are you GZIPPing twice ? i.e. is something already compressing parts of your site ?

  6. prince211986
    Member
    Posted 1 year ago #

    i want create new cache server. how this possible. and how was create this????????

  7. Mike McKoy
    Member
    Posted 1 year ago #

    Server config? No way. Not after years of use and this one update messing everything up.

    I've said before compression is turned off completely. Serverwide and in WordPress.

    We aren't having any problems now that we are using WP-Supercache. So for us its resolved. We can't use a product that doesn't QA but I hope its finally fixed.

  8. robnalexpress
    Member
    Posted 1 year ago #

    Adding

    AddDefaultCharset utf-8

    to the htaccess file in the wp-content/cache/page_enhanced folder fixes it for me, except that every time I disable and then activate W3TC the plugin re-writes the code, and I have to add it back again. I hope Frederick with address this in the next update.

  9. Nic Windley
    Member
    Posted 1 year ago #

    add AddDefaultCharset utf-8 to your top level / root htaccess and you no long need to worry about W3TC overwriting it robnalexpress

  10. robnalexpress
    Member
    Posted 1 year ago #

    @ Nic Windley- Thanks! That seems to have done the trick!

  11. jimario
    Member
    Posted 1 year ago #

    I had this problem too except that my entire page had nothing but crazy random characters whenever the W3 Total Cache was enabled. The above fix using .htaccess did not work.

    After countless googling, I found out that Bluehost where I host my sites, had updated all WordPress installations on their servers as well as updated all W3 Total Cache plugins because of a security vulnerability. They did so without warning.

    My site is a custom theme that used an old TwentyTen theme as the starting point. So what I did was copied the code from my header.php file and pasted it into the header.php file of a newer theme. I only copied the code after <body <?php body_class(); ?>> and pasted it accordingly. That did the trick.

  12. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Have you guys tried enabling compability mode on the Page Cache settings page when using Disc:Enhanced?

    @jimario Your original problem looked  like a case of having multiple gzip features enabled. Perhaps some other plugin or some setting in htaccess. Those random chars is due to gzip being run twice. The random chars in those cases covers the whole cached pages.

  13. Alperian
    Member
    Posted 11 months ago #

    This fixed my problem in Joomla! too!! Whey hey!

  14. TheVirtualPreacher
    Member
    Posted 6 months ago #

    I had the same problem and adding AddDefaultCharset utf-8 to wp-content/cache/page-enhance/.htaccess did not work. (I did not try adding it to /.htaccess though). However I tried completely uninstalling the plugin and re-installing and the problem vanished.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic