WordPress.org

Ready to get started?Download WordPress

Forums

Page background not showing up (5 posts)

  1. excentriqua
    Member
    Posted 8 years ago #

    Thanks to some help here before, I'm on my way to transfering my old HTML webpage (http://obliviouslyyours.com/blog.html) to the beginnings of a WordPress template. The new URL is http://obliviouslyyours.com/blog

    If you look at the previous layout, I have a repeating background image going throughout the page. I want to repeat this in my theme, but I'm having trouble. There was a note in my style.css that said to put images in index.php, so that's what I tried to do (though with a CSS tag). Currently I have this at the top of index.php:

    <*style type="text/css">
    body
    { background: #fff370;
    background-image: url(images/bg.gif);
    background-repeat: repeat-y;
    background-attachment: scroll;
    background-position: 0% 0%;
    </*style>

    The image isn't showing, and normally I would just gather that it was in the wrong place...yet the background *color* did show up and apply to the page. I've also tried putting this note in the body of style.css, but it hasn't worked there, either.

    Any suggestions?

    P.S. Also, as you can see, I'm having problems with starting my content and sidebar at the same time. I think this might be because I messed with the margins, but I don't know. And is there any way to get rid of those lines dividing sections? I have a hr note in my style.css (*hr { display: none;}), but it doesn't seem to be helping...

    I'm sorry for being so demanding, lol, but I didn't want to create a lot of seperate topics. I'd greatly appreciate anything you'd have to add! Thanks. =)

  2. Kafkaesqui

    Posted 8 years ago #

    1. <style> tags should reside in the <head> of a document. You have it appearing even before DOCTYPE. Not good.

    2. You need to properly close css declarations (for every { there should be a }).

    3. Ignore the instructions and place it in your style.css. Trust me.

    4. If it's the *bottom* section you're trying to set a background image to, then you may want to focus on setting this for the #wrapper div instead of the body of the document (otherwise you're just covering it up with the background settings of everything else).

    5. Any idea why your wrapper div shows up like this:

    <div id=�wrapper�>

    Note: I'd focus on the basics here first before looking into other problems.

  3. oriecat
    Member
    Posted 8 years ago #

    Could be because your background image is title alt.gif instead of bg.gif?

  4. Kafkaesqui

    Posted 8 years ago #

    There is a bg.gif, but it resides in the images directory that's tucked away in the theme directory. Hence my #3 above.

  5. excentriqua
    Member
    Posted 8 years ago #

    Ah, thank you Kafkaesqui! I had just copied and pasted a general wrapper from a tutorial, and the text had a fancy sort of quotation mark the computer didn't recognize. Now the background image is showing up. Thanks! All I need to do now is align everything, lol.

Topic Closed

This topic has been closed to new replies.

About this Topic