WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Padding at left of page (7 posts)

  1. Chateaupoulet
    Member
    Posted 1 year ago #

    Hi there,

    I am trying to decrease the padding on the left of the pages on a site. The theme is 2010. The site is http://www.bridgetlansley.com

    For example the About page is using "one column, no sidebar" which gives a large left margin/padding.

    I have tried changing

    #content textarea {
    color: #333;
    font-size: 14px;
    line-height: 18px;
    padding-left: 85px;
    }

    and putting in a padding of, say 85px, but this just increases the existing padding even more. I would like to be able to set it so that it lines up with the menu and header image text. I would like to be able to do the same with the page titles.

    I suspect I'm looking in completely the wrong place!

    Many thanks if anyone is able to help.

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    There is no such thing as "textarea" -- with CSS you need to use a class or an id or a tag.

    For what you want to do, you need to look at the CSS for:

    .one-column #content

    It's set in both style.css and nggallery.css.

    Are you using Firebug to work with CSS? Also see this which is a good basic reference:

    http://www.w3schools.com/css/

  3. Chateaupoulet
    Member
    Posted 1 year ago #

    Thank you. I am starting to learn how Firebug works. Very useful. I found .one-column #content using Firebug and then tried various things in the editor but nothing changed. It is back to the original setting of

    .one-column #content {
    margin: 0 auto;
    width: 900px;
    }

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Actually, it's now set at 640px. Is that what you want. If you are still trying to get it to be wider and align with the menu, try using 810px -- that looks about right.

  5. Chateaupoulet
    Member
    Posted 1 year ago #

    That's working WPyogi, thank you very much!
    The CSS that is being applied is from nggallery.css, and not style.css.

    I seem to have overwrittren the original nggallery with code from a style.css file last week. I think I might need to reinstall the gallery plugin/

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Yeah, and really it's VERY strongly recommended that you not be changing the CSS in either of those files, but rather in a Child Theme. As is, you'll lose all your changes (at least in the style.css file) when the theme or WP (since you're using a default theme) is updated. So it would be worth your time/effort to go back and do that.

  7. Chateaupoulet
    Member
    Posted 1 year ago #

    Thanks again. I'll do that now.

    Learnt a lot today!

Topic Closed

This topic has been closed to new replies.

About this Topic