WordPress.org

Ready to get started?Download WordPress

Forums

Paaaainfully slowwwwww (8 posts)

  1. LoriEhrlich
    Member
    Posted 8 years ago #

    I didn't mind so much that Word Press was so slow when it was just me posting, but now my writers are all complaining. The interface seems to make my site the slowest site to load on the web.

    Am I doing something wrong? My webhost (Network Solutions) looked into it and determined it was Word Press.

    Please advise or I'll need to look into another program.

  2. Michael Bishop

    Posted 8 years ago #

    It's not WP. It may be a combination of several issues related to WP, but it's not WP by default.

    First, read through the Speed Test for your site You have a lot of images, that need to be optimized. You may want to look at the plugins you have installed. It's possible one of them is causing some issue. What are you using to make the photo album? That could be the issue as well.

  3. febwa1976
    Member
    Posted 8 years ago #

    Lori - Just fyi - I just went to your site and it took more than 30 seconds to load (hi speed cable from Europe). My sites which are with US based hosts take between 3 and 6 seconds.

    Where I have an issue is at the backend - the time to post and save and edit posts - there are several threads here about that.

  4. LoriEhrlich
    Member
    Posted 8 years ago #

    Thanks for these responses, miklb and febwa. I'm using the Photopress plugin for the album.

    I ran that speed test which indicated this:

    # This site is not using HTTP compression, otherwise called content encoding using gzip. Consider compressing your textual content (XHTML, JavaScript, etc.) with mod_gzip or similar products.

    Is mod_gzip a plugin? I'm learning as I go.

    Will this take care of the backend problem (like febwa1976) too?

    Thanks again for responding.

  5. LoriEhrlich
    Member
    Posted 8 years ago #

    I disconnected podpress and that sped things up a bit. I'll miss it, of course.

    I still look forward to your wisdom on mod_gzip.

    thanks.

  6. Chris_K
    Member
    Posted 8 years ago #

    mod_gzip is, as you might guess, an apache module. You'll want to check with your host to see if it is available on your server. If it is, visit Options -> Reading and check the box by "WordPress should compress articles (gzip) if browsers ask for them" towards the bottom of the page.

  7. resiny
    Member
    Posted 8 years ago #

    yeah, check images (another thread had a guy with a 200kb image)

    if you look at the link above you see that just a couple images are totaling nearly 100kb. You can easily get that down to 50.

    Other than that, it loaded decently for me

  8. sparkletack
    Member
    Posted 7 years ago #

    PodPress tip...

    The number of files that can be inserted to a post is set very high in PodPress - 250 or so.

    To change that number:

    from wp-admin, podpress, general
    Post Editing
    Max Number of Media Files: (change this to 2)

    Good luck!

Topic Closed

This topic has been closed to new replies.

About this Topic