WordPress.org

Ready to get started?Download WordPress

Forums

P2
[resolved] p2 theme does not add media from front page (7 posts)

  1. davouch
    Member
    Posted 1 year ago #

    WP 3.6-alpha-23334
    P2 Version 1.4.2
    Running at localhost under XAMPP @ WinXP Pro

    There is no response after the click on the Add media link on top of the front page.

    After clicking the link nothing appears and Firebug shows this error:

    TypeError: e is undefined [Break On This Error] 	
    
    ...},T.memoize=function(e,t){var n={};return t||(t=T.identity),function(){var r=t.a...
    
    http://localhost/lndn/wp-includes/js/underscore.min.js?ver=1.4.1

    The error remains even with no plugins activated.

    Any help is going to be greatly appreciated. :)

    http://wordpress.org/extend/themes/p2/

  2. invot
    Member
    Posted 1 year ago #

    Sounds like a bad WordPress install. If you can manage your site via FTP or something you can download that file and replace it.

    http://underscorejs.org/

    If that doesn't work, try reinstalling WordPress. You can do this without uninstalling it, just re-apply the latest update.

  3. davouch
    Member
    Posted 1 year ago #

    Thanks, @invot, for landing here. I'm not sure, if you've noticed that in my initial post, but I'm running this thing on a localhost (for more specs see above).

    To your suggestion, I've tried that already, even before posting the whole thing here. However, when I've tried that with their minified version, the console snapped back, it's unable to get the 1.4.1 version, which seemed weired, so I reverted back to original file shipped with wp.

    Now trying it again with the non-minified, the error changed to this:

    Uncaught TypeError: Cannot call method 'on' of undefined media-views.min.js:1
    f.controller.State.Backbone.Model.extend._updateMenu media-views.min.js:1
    w backbone.min.js:8
    g.Events.trigger backbone.min.js:10
    f.extend.set backbone.min.js:13
    g.Model backbone.min.js:12
    f.controller.State.Backbone.Model.extend.constructor media-views.min.js:1
    d backbone.min.js:41
    f.view.MediaFrame.Post.f.view.MediaFrame.Select.extend.createStates media-views.min.js:1
    f.view.MediaFrame.Select.f.view.MediaFrame.extend.initialize media-views.min.js:1
    f.view.MediaFrame.Post.f.view.MediaFrame.Select.extend.initialize media-views.min.js:1
    g.View backbone.min.js:36
    f.View.Backbone.View.extend.constructor media-views.min.js:1
    d backbone.min.js:41
    d backbone.min.js:41
    d backbone.min.js:41
    d backbone.min.js:41
    wp.media media-models.min.js:1
    wp.media.editor.add media-editor.min.js:1
    wp.media.editor.open media-editor.min.js:1
    (anonymous function) media-editor.min.js:1
    jQuery.event.dispatch jquery.js:3045
    elemData.handle

    Also there's been this line in java console since the very beginning:
    JQMIGRATE: jQuery.fn.live() is deprecated jquery-migrate.js:29

  4. davouch
    Member
    Posted 1 year ago #

    One more error kicks in after a while:
    JQMIGRATE: jQuery.browser is deprecated jquery-migrate.js:29

  5. davouch
    Member
    Posted 1 year ago #

    Updated to
    3.6-alpha-23386
    with no change. Error remains, 'add media' link doesn't respond.

  6. davouch
    Member
    Posted 1 year ago #

    Bingo!
    After reverting back to the official release WP 3.5.1, the front page add media link works properly. (the WP 3.5 works too)

    Thanks for your help.

  7. davouch
    Member
    Posted 1 year ago #

    It's a trunk version issue:
    http://core.trac.wordpress.org/ticket/23262

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags