WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] P2 preview or activation HTTP Error 500 (3 posts)

  1. obsolete
    Member
    Posted 5 years ago #

    WordPress works and Prologue 1.4.1 runs fine.
    When trying to activate (or preview) P2 theme, HTTP Error 500 is displayed. Other themes can be previewed.

    IIS Log:
    2009-04-18 00:16:47 W3SVC1314376923 x.x.x.x GET /index.php preview=1&template=p2&stylesheet=p2& 80 - x.x.x.x Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322) 500 0 0

    WordPress installed on private server.
    Wordpress 2.7.1
    IIS 6
    PHP Version 5.2.9-1
    MySQL 5.1.32

  2. obsolete
    Member
    Posted 5 years ago #

    PHP Error:
    Parse error: parse error in X:\X\wordpress\wp-content\themes\p2\functions.php on line 729

    This is P2 1.0.3 revision 1866
    From SVN http://svn.automattic.com/wpcom-themes/p2

  3. obsolete
    Member
    Posted 5 years ago #

    Fixed in http://wordpress.org/support/topic/255088?replies=21
    Thanks to @lilyfan.

    From the other thread post by lilyfan:

    The fix point is below.

    * line 429 of functions.php
    <div class="postcontent<?php if (current_user_can( 'edit_post', get_the_id() )) {?> editarea<?}?>"....

    should be:
    <div class="postcontent<?php if (current_user_can( 'edit_post', get_the_id() )) {?> editarea<?php } ?>"

    For me the line was 723.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags