WordPress.org

Ready to get started?Download WordPress

Forums

P2 1.1.1 Problems (13 posts)

  1. omarkassim
    Member
    Posted 4 years ago #

    Hi Everyone,

    I was on WP 2.8.6 and decided to upgrade P2 to the latest version that came out this evening (for me) - i.e. 1.1.1.

    After upgrading P2, I realised that 1.1.1 is in fact only compatible with WP 2.9 beta and above. I wish I had read the release notes.

    I upgraded WP to the latest beta 2.9 release and then followed this up with the latest nightly build. Unfortunately P2 still does not work as expected.

    At the moment, I can see the new posting interface (new tabs) and a title of my last post (no post content) and just the sidebar. Nothing else is displayed.

    I am not too sure what has gone wrong.

    Please have a look at http://www.omarkassim.com to see what I mean - I may change this in a few hours if I can't get to a workable solution.

  2. thesmudger
    Member
    Posted 4 years ago #

    I too have had what sounds to be the same problem (tried the same solution to). I have already posted a request for help on another post (P2 not installing). Following is a copy of the text I posted ---- Is there a means to full back to the previous version (P2.1). I have updated automatically to find that the theme info now says that it is configured to work with 2.9 beta or better and, if I try to use I get an error message - Fatal error: Call to undefined function: str_ireplace() in /homepages/45/d141821370/htdocs/archery/wp-content/themes/p2/functions.php on line 69 - and this is a shame. If I'd have known this was suitable for 2.9 beat and above I would have waited it out, now I can't roll it back and I am having to use another theme which I don't really want to. Any assistance would be appreciated.

  3. everydream23
    Member
    Posted 4 years ago #

    Same here on error in line 69. I wanted to update my page... lost everything. I don't blame them for the whole loss of information (i shoulda backed up) but to place something on the "featured" themes and not have it compatible with the public release is ridiculous. I am sure others will have this problem...

    kinda disappointed... and pissed.

  4. Nobble
    Member
    Posted 4 years ago #

    Have you guys tried reverting back to the previous P2 theme?

    I think they were intending to release it along side wp 2.9's release. As a developer I loved that they released it a little earlier...and perhaps wp 2.9 isn't that far away now.

    I can send along the older p2 theme if anyone wants it.

  5. everydream23
    Member
    Posted 4 years ago #

    Nobble,

    that would be great. let me know how you want to send it... email? or is it located on a site?

  6. Brian
    Member
    Posted 4 years ago #

    I simply deleted that line (69) and for the moment that seems to be working in the non-beta version of my wordpressmu installation.

  7. Nobble
    Member
    Posted 4 years ago #

    link to the previous version of p2:
    http://www.mediafire.com/file/m0qoywzw1tm/p2.zip

  8. noel
    Member
    Posted 4 years ago #

    What errors is everyone getting?

    str_ireplace is a PHP 5 only function. I will make a P2 1.1.2 release that contains the proper PHP4 equivalent.

    Any other errors? I can only help if you can help me track down the problem.

  9. everydream23
    Member
    Posted 4 years ago #

    Thanks Nobble! Appreciate it much!

    Noel,

    That would be great. Let me know if you complete that and how to get ahold of that build.

    or if you can post the code on here as the replacement...

  10. Brian
    Member
    Posted 4 years ago #

    Noel, my problem may very well have been the str_ireplace function problem. I'd only just noticed I was running on only PHP 4 at my client's host when I did any install of nextgen gallery. I switched it over to PHP 5 yesterday and so will see if it now works. That was my only problem so far.

  11. Brian
    Member
    Posted 4 years ago #

    As a stopgap measure, does deleting that one function call, at line 69, really hurt anything?

  12. noel
    Member
    Posted 4 years ago #

    @summae deleting that line may mess up some of the @name linkage and taxonomy support, but not too harmful.

  13. RachVG
    Member
    Posted 4 years ago #

    I notice there was a link to the previous version of P2 posted above, but it's been removed from Mediafire now. Does anybody still have it?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags