WordPress.org

Ready to get started?Download WordPress

Forums

Edge Suite
[resolved] Overflow problem? (15 posts)

  1. nanodaman
    Member
    Posted 1 year ago #

    I am working on a website and added an animation of clouds flowing using adobe edge animation.

    http://avuedesigns.com/iaq/

    I have created a thread over at the adobe community (http://forums.adobe.com/thread/1128782) and it seems that my code to make it responsive, and the overflow are correctly setup.

    So basically I have no idea why WordPress is either breaking it. Or why my little bit of code thinks the website is wider than it really is. Maybe fresh eyes can see something I am not.

    http://wordpress.org/extend/plugins/edge-suite/

  2. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    by looking at your code I seems you are using the header placement method ("Placement method B" http://edgedocks.com/content/edge-suite-integrate-edge-animate-wordpress). But there is no stage div in the source which probably results from leaving out the header.php edits as described in the tutorial. When there is no stage div edge will place the animation in the body and it won't work as intended (as in your case with the overflow). Hope that helps.

    Note: This seems to be highly related to http://wordpress.org/support/topic/unable-to-center-edge-stage-whle-using-plugin as I think you are also trying to place the animation behind the actual content.

  3. nanodaman
    Member
    Posted 1 year ago #

    So how do I get it not to attach it self to the body? Could I just place it into a div?

  4. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    As said, please check the tutorial at http://edgedocks.com/content/edge-suite-integrate-edge-animate-wordpress

    When using the header method you need to insert

    if(function_exists('edge_suite_view')){
       echo edge_suite_view();
    }

    into your template, otherwise use shortcodes.

  5. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Over at the other issue ( http://wordpress.org/support/topic/unable-to-center-edge-stage-whle-using-plugin ) I just posted a bit of CSS that you can try to use to put the animation in the background.

  6. nanodaman
    Member
    Posted 1 year ago #

    I didnt place the php code in the header, I have it in another file. I have reread the steps over and over and assure you that I have done these steps, and the settings are set to the images.... I still do not understand

  7. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    In which file did you put the PHP code? What theme are you using? I can just tell you that the stage div doesn't show up in the HTML code and it looks like the PHP from above doesn't get called. Otherwise just give twentyeleven a try and check if it all works there, then you might know what to change in your theme.

  8. nanodaman
    Member
    Posted 1 year ago #

    I pasted the php code where the slider is located.

    Im using this theme: http://themeforest.net/item/rounder-multipurpose-adaptive-wordpress-theme/3387754

    {if $options->sliderEnable == 1}
    	{if $options->sliderType == 'anything'}
    		{var $slides = $site->create('slider-creator', $options->sliderCategory)}
    		{if $slides}
    			<ul id="slider">
                 <?php
              if(function_exists('edge_suite_view')){
                echo edge_suite_view();
              }
            ?>
    			{foreach $slides as $slide}
    			<li>
    				<a href="{$slide->options->link}">
    				{ifset $slide->options->topImage}
    					{if (!empty($options->sliderHeight))}
    					<img src="{$timthumbUrl}?src={$slide->options->topImage}&w=920&h={$options->sliderHeight}" alt="{$slide->options->description}" />
    					{else}
    					<img src="{$timthumbUrl}?src={$slide->options->topImage}&w=920&h=442" alt="{$slide->options->description}" />
    					{/if}
    				{/ifset}
    				</a>
    
    				{if $slide->options->descriptionPosition != 'hide'}
    				<div class="entry-content anything-caption caption-{$slide->options->descriptionPosition}">
    			       	{!$slide->options->description}
    			    </div>
    			    {/if}
    			</li>
    			{/foreach}
    			</ul>
    		{/if}
    	{elseif $options->sliderType == 'revolution'}
    		{if $options->sliderAliases != 'null'}
    			{if isset($options->sliderAlternative)}
    			<div class="slider-alternative" style="display: none">
    				<img src="{$options->sliderAlternative}" alt="alternative" />
    			</div>
    			{/if}
    
    			{putRevSlider($options->sliderAliases)}
    		{/if}
    	{/if}
    {/if}
  9. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    PHP doesn't seem to run into the IF branch where the stage gets printed. If you look for <ul id="slider"> in the HTML page source you won't find that either. I would pull the whole snippet out of the if clause anyway, putting the stage div into an UL tag isn't valid HTML. If you really want to keep it there then you need to make sure that $options->sliderEnable == 1 and $options->sliderType == 'anything' evaluate to true, but as said, don't think that's a good idea, just pull it to the top and see what happens.

  10. nanodaman
    Member
    Posted 1 year ago #

    I swear this has a mind of its own. Do you offer any services to take a look at this for me? I remove the lines of code, and some how the animation is still going.... I just do not understand what is going on...

  11. nanodaman
    Member
    Posted 1 year ago #

    After turning off: pages > home > edge suite = none; all animation is off. I reput the code snippet in the silder.php like before and nothing happened. For some odd reason, the animation only play when I had the php code in slider.php (when really it was not doing anything all) and thats why it seemed like it was working. But this whole time, just the default setting with in the "page" was on, but only work when I was trying to add the line of code, which is why it is showing in the body like you created it to do.

    ... soo after figuring this all out, I guess I am at step one again.

    Which is, what would be the best option for me to get the clouds flowing behind that slider.

    I would donate, pay you for your time, whatever you want.

  12. nanodaman
    Member
    Posted 1 year ago #

    It seems like I got it to print the div stage. But for some reason it is giving it a width of 0? I know something is causing it not to expand, just got to figure that part out...

  13. nanodaman
    Member
    Posted 1 year ago #

    figured it out

    when i change the css element *in google chrome tools*

    element.style { position:absolute;} is works

    Just need to see where that is located at...

  14. nanodaman
    Member
    Posted 1 year ago #

    I read over the link you gave me supporting the other guy. I added position: absolute !important; and it work. Without the !important; it just does not work like you pointed out.

    Yaya! ... =P

  15. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    As I understand it is working now so I'm closing the issue. If not feel free to reopen.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.