WordPress.org

Ready to get started?Download WordPress

Forums

Overflow blocking add to cart, product description (10 posts)

  1. caclark4
    Member
    Posted 2 years ago #

    Hello. I am using the theme "crafty cart" and WP e-Commerce plug-in. On a product page, the description and the "add to cart" button are overflowing and require the use of the scroll bar to access. I am really rusty in fixing CSS and HTML. In order to fix this issue:

    1) Do I access the theme or the WP e-Commerce .php's? Which file do I access?
    2) What line and code do I need to change?

    I see others have been able to correct this issue but I have not found the how-to.

    A sample page is http://youcrazykids.com/?wpsc-product=cute-as-hell-onesie-2. Thank you so much in advance!

  2. WPyogi
    Volunteer Moderator
    Posted 2 years ago #

    The problem is that this

    #single_product_page_container {
        position: relative;
        width: 650px;
    }

    The above is being set by the ecommerce plug-in css
    and it is wider than the element is it contained in here in style.css:

    div.large {
        float: right;
        width: 600px;
    }

    Try adding this to your style.css file:

    #single_product_page_container {
        width: 580px !important;
    }
  3. caclark4
    Member
    Posted 2 years ago #

    I cannot find the "single product" code section. Can you provide me with more direction please?

  4. WPyogi
    Volunteer Moderator
    Posted 2 years ago #

    The above is being set by the ecommerce plug-in css

    http://youcrazykids.com/wp-content/plugins/wp-e-commerce/wpsc-theme/wpsc-default.css?ver=3.8.8.1.545444'

  5. caclark4
    Member
    Posted 2 years ago #

    The only problem with making that change is that it also affects the first page as well. The blog post floats above the menu. Any other ideas?

  6. caclark4
    Member
    Posted 2 years ago #

  7. WPyogi
    Volunteer Moderator
    Posted 2 years ago #

    Yes, that is the page I was looking at when I replied earlier. What "first page" are you referring to here:

    The only problem with making that change is that it also affects the first page as well. The blog post floats above the menu.

  8. caclark4
    Member
    Posted 2 years ago #

    I'm sorry. The index page.

  9. WPyogi
    Volunteer Moderator
    Posted 2 years ago #

    Can you give a specific URL -- that shows the problem? And what code, exactly, did you change and where?

  10. caclark4
    Member
    Posted 2 years ago #

    I don't believe the issue is related to the WP E-commerce because the issue exists outside of importing the e-commerce theme settings.

    As directed, I went to the wpsc-default.css sheet and changed
    /*-----SINGLE PRODUCTS PAGE-----*/
    #single_product_page_container {
    width:650px;
    position:relative;
    }

    to

    /*-----SINGLE PRODUCTS PAGE-----*/
    #single_product_page_container {
    width: 580px !important;
    }

    The first time I did this, I changed the wrong css file. I reverted back to a fresh page and with the change noted above, there is no change to the index page (youcrazykids.com) or to the product link.

Topic Closed

This topic has been closed to new replies.

About this Topic