WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] "Otimize More" option not available (9 posts)

  1. almarma
    Member
    Posted 8 months ago #

    Hi,

    First, congratulation for this very useful plugin! I'm using it on several of my WP sites. It works fine on all of them, specially after updating to 1.7.1.9.

    But in one of my sites (informateca.net), I don't have the option to update the files out from the media gallery, by using the "Optimize more" button. It was not available with 1.7.1, neither with 1.7.1.9. I've tried also to add the wp-content folder in the EWWW options field called "Folders to optimize", but after saving the changes, the field is empty again. I also tried to delete the plugin and installing it again, but the settings are kept. Is there any way to fully reset EWWW to try to get rid of any old settings issue? It's strange, because it works perfectly on my other sites, and all are hosted on the same server.

    I'm using WP 3.7.1, and here is the debug info FYI: http://pastebin.com/aK4drws2

    Thanks in advance and regards!!

    http://wordpress.org/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    Ok, I'm not sure I quite understand the first issue. Do you mean that there is no Optimize More menu under Tools?

    Then, I assume you mean that you tried to add this folder to the options page: /home/lofotenr/public_html/informateca.net/wp-content/

    Note that you need to specify the full path, like it is above.

    I'm not sure resetting the settings will do anything, but the only way to do that is to go into the wp_options table and remove any setting that has the name of the plugin in it.

  3. cjerrells
    Member
    Posted 8 months ago #

    Hi,

    +1 for thanks on creating such a useful plugin :)

    I'm also having the issue that no "Optimize More" menu appears under Tools. I also don't see the Buddypress menu I think should be there since I have BuddyPress installed.

    I just upgraded to v1.7.1 (on WP 3.7) and I still see the "Bulk Optimize" menu under "Media" and the usual EWWW plugin settings page under "Settings" but no other admin menu items.

    I've tried disabling and re-enabling the plugin. I haven't tried deleting and re-installing the plugin yet, thought I'd check here first.

    Output from EWWW Debug here:
    http://pastebin.com/ds9U9Qj9

    Any help appreciated! Thanks.

  4. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    Are either of you using multisite?

  5. cjerrells
    Member
    Posted 8 months ago #

    No, I'm not.

  6. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    The only thing it checks on that menu item is for this permission: edit_themes

    Can you confirm that your user account has this permission? It sounds like it should, but perhaps you (or someone else at your site) has customized your user role?

    To check, see if you have these two menu items under Appearance/Themes:
    Optimize & Editor

  7. cjerrells
    Member
    Posted 8 months ago #

    I'm logged in as the main site administrator account. No customisation of user roles as far as I know.

    In the Appearance menu, I have Themes, Widgets, Customize, Menus and Theme Test Drive.

    The only thing I can think of which could be interfering with edit_themes is that we run the Better WP Security plugin with the option "Turn off file editor in WordPress Back-end" to disable in-dashboard theme file edits. But I've just tried disabling that option and it didn't make the EWWW menu items appear.

    Should I update to 1.7.2?

  8. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    Go ahead and update, but I don't think it will make any difference. Are you sure about that setting? I just installed the plugin on my dev box, enabled basic security, and nothing changed on the Optimize More menu item. I checked the box for 'Turn off file editor in WordPress Back-end' and saved the settings (changed nothing else), and Optimize More disappeared.

    Try this fix (delete the plugin, and upload it via the dashboard from this dev package): http://downloads.wordpress.org/plugin/ewww-image-optimizer.zip

  9. cjerrells
    Member
    Posted 8 months ago #

    Thanks for the reply.

    Yes, I checked the setting. WP Better Security is reporting "You are allowing users to edit theme and plugin files from the WordPress backend." and still no extra menu items for EWWW.

    Also tried updating, no change.

    I installed the custom version you provided, and the menu items have appeared! "BuddyPress Optimize" under Media, "Optimize" under Themes, and "Optimize More" under Tools.

    Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.