WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] OS reinstalled WordPress not working (9 posts)

  1. DarkSnake-Kobra
    Member
    Posted 2 years ago #

    I while back ago I made a decision to switch from Ubuntu Sever 11.10 to CentOS 6 and after realizing that I didn't have enough ram(256MB) and put it on hold until I got more ram. I ended up going back to Ubuntu Server however I get the error when connecting "HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request."

    I backed up the entire /var/www folder and exported the database through phpmyadmin and imported it back. Unless something is messed up?

  2. RichardWPG
    Member
    Posted 2 years ago #

    It has gotta do something with your database. You may want to check your database credentials first

  3. DarkSnake-Kobra
    Member
    Posted 2 years ago #

    I'm just an average Linux user so you'll have to bare with me. Not sure exactly how to do that? I did recreate the user/password with privileges to the database if that's what you are asking.

    Is it possible to do a clean install of wordpress and import the old database into the new so I have all the content back?

  4. maoski
    Member
    Posted 2 years ago #

    Is it possible to do a clean install of wordpress and import the old database into the new so I have all the content back?

    what i would do is do a clean install of WP and make sure that works first.

  5. DarkSnake-Kobra
    Member
    Posted 2 years ago #

    Will do that. :)

  6. DarkSnake-Kobra
    Member
    Posted 2 years ago #

    I got wordpress reinstalled now and working. How would I import and use the old database?

  7. maoski
    Member
    Posted 2 years ago #

    create a brand new database try and use another name to your exisitng database

    import the sql file into the new database

    change the credentials in the wp-config file to reflect your new (imported) database's name

    things might look messed up or not work because their will be theme and plugin tables in your (imported) database. try replacing the wp-content folder with your old folder.

    see how that goes anyway, another issue might be the versions of wordpress (old vs new)

  8. DarkSnake-Kobra
    Member
    Posted 2 years ago #

    Ok. I did get the old database working and looks fine, but I need to wait for my domain registrar to fully propagate the changes(url mapping to the server) as the links/content are dead. Seemed to take awhile the last time(a week) so I'll post back when that's fixed. :)

  9. DarkSnake-Kobra
    Member
    Posted 2 years ago #

    I just did a reinstallation and will be manually adding the content back. Thanks for the help and suggestions. :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.