WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] optipng path: gifsicle path: pngout path: ALL BLANK (37 posts)

  1. serkis
    Member
    Posted 1 year ago #

    I have optipng and gifsicle in the /wp-content/ewww directory but its not "seeing" it, but its seeing jpegtran
    ===============================================
    jpegtran: UPDATE AVAILABLE* Install automatically | manually version: Independent JPEG Group's JPEGTRAN, version 8b 16-May-2010
    optipng: MISSING Copy binary from /hermes/bosweb25a/b209/nf.XXXX/public_html/blog/wp-content/plugins/ewww-image-optimizer/ to /hermes/bosweb25a/b209/nf.XXXX/public_html/blog/wp-content/ewww/ or Download optipng source
    GD: OK   Imagemagick 'convert': OK
    safe mode: Off  exec(): OK  shell_exec(): OK  finfo: MISSING  getimagesize(): OK  mime_content_type(): MISSING
    Operating System: Linux
    Debug Info

    jpegtran path: jpegtran
    optipng path:
    gifsicle path:
    pngout path:
    disabled functions:
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0755
    user: nf.XXXX

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Did you copy them over manually, or did the plugin do it automatically?

  3. andrebazaglia
    Member
    Posted 1 year ago #

    Same problem here! I tried both automatically and manual install.

    In my debug, I have:

    jpegtran path: jpegtran
    optipng path:
    gifsicle path: gifsicle
    pngout path:
    disabled functions:
    gifsicle permissions: 0755
    optipng permissions: 0755
    wp-content/ewww permissions: 0777
    user: apache

  4. serkis
    Member
    Posted 1 year ago #

    sorry for the late response

    yes - manually copied
    and tried automatic

  5. andrebazaglia
    Member
    Posted 1 year ago #

    It looks like that my wp-content/ewww isn't being read. Even thought I tried manual and automatic, I keep getting "UPDATE AVAILABLE" for all the options. wp-content/ewww is already 777. But not works :(

    Also tried to copy the files manually to /usr/local/bin, and no success!

  6. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    andrebazaglia, do you have the ability to install software on your system?

  7. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    serkis, can you find out what specific OS and version you are running? is it CentOS, RedHat, Fedora, Ubuntu, etc.?

  8. andrebazaglia
    Member
    Posted 1 year ago #

    @nosilver4u, yes. I can install software on my system, CentOS. jpegtran, optipng and gifsicle were installed using yum command.

  9. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    hmm, can you paste the output when you run this:

    optipng -v

  10. andrebazaglia
    Member
    Posted 1 year ago #

    OptiPNG 0.6.4: Advanced PNG optimizer.
    Copyright (C) 2001-2010 Cosmin Truta.

    This program is open-source software. See LICENSE for more details.

    Portions of this software are based in part on the work of:
    Jean-loup Gailly and Mark Adler (zlib)
    Glenn Randers-Pehrson and the PNG Development Group (libpng)
    Miyasaka Masaru (BMP support)
    David Koblas (GIF support)

    Using libpng version 1.4.1-optipng and zlib version 1.2.3

    The optipng was installed when I've run 'yum install optipng', however, optipng, jpegtran and gifsicle are running an old version, even though I copied the newest files to the correct folder, as the plugin asked.

  11. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    3 things then:
    andrebazaglia, Can you paste the Plugin Status section also? I'm a little puzzled as to why it isn't detecting optipng when you very obviously have it installed and I thought I had fixed the bug with older versions (like optipng 0.6.4).

    You are running version 1.3.7 of the plugin, right?

    A separate issue would be why CentOS isn't using the bundled tools. I've got a CentOS 5 dev box that runs them just fine. Do you know what version of CentOS you are using?

  12. andrebazaglia
    Member
    Posted 1 year ago #

    Hi,

    Firstly, thank you for all the help. I'm using CentOS 6 and version 1.3.7 of your plugin. Here's my plugin status: [Link to the screenshot]

  13. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, one last question before I go do some checking. Is it 32-bit or 64-bit? You can generally run 'uname -a' to see. Look for something like i686 for 32-bit or x86_64 for 64-bit.

  14. andrebazaglia
    Member
    Posted 1 year ago #

    64-bit!

  15. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    I wonder if there is some sort of library that needs installed for 32-bit binaries that might do the trick?
    What output do you get if you browse to the wp-content/ewww folder on the command line and run the optipng binary there?
    Something like this: ./optipng -v

  16. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

  17. andrebazaglia
    Member
    Posted 1 year ago #

    When I go to wp-content/ewww and run ./optipng -v, I get:

    OptiPNG version 0.7.4
    Copyright (C) 2001-2012 Cosmin Truta and the Contributing Authors.

    This program is open-source software. See LICENSE for more details.

    Portions of this software are based in part on the work of:
    Jean-loup Gailly and Mark Adler (zlib)
    Glenn Randers-Pehrson and the PNG Development Group (libpng)
    Miyasaka Masaru (BMP support)
    David Koblas (GIF support)

    Using libpng version 1.4.12 and zlib version 1.2.7-optipng

    This shows the newest version exists in the directory, however it still not being used by the plugin. I tried following your instruction and run "yum install glibc.i686", however, the package was already installed.

  18. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    And you don't have the setting checked to 'Use system paths'?

  19. andrebazaglia
    Member
    Posted 1 year ago #

    Thank you again for your reply. "Use system paths" is unchecked.

  20. serkis
    Member
    Posted 1 year ago #

    without calling my webhost support I was able to grab this info

    Platform Type: Debian
    MySQL Version: 5.0.91-log
    Perl Version: 5.8.8
    PHP Version: 5.3.13
    Path to PHP: /usr/local/bin/php

  21. serkis
    Member
    Posted 1 year ago #

    also running WordPress 3.4.2.
    about to upgrade to 3.5

  22. serkis
    Member
    Posted 1 year ago #

    1 suggestion the error is

    optipng: MISSING Copy binary from /hermes/bosweb25a/b209/nf.stmarytoronto/public_html/blog/wp-content/plugins/ewww-image-optimizer/ to /hermes/bosweb25a/b209/nf.stmarytoronto/public_html/blog/wp-content/ewww/

    but on my webhost for security reasons obviously I can only see inside
    /hermes/bosweb25a/b209/nf.stmarytoronto/, so in other words I can't navigate from the true root

    perhaps the plugin is also under the same restrictions???

  23. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    serkis, 2 questions:
    1. do you have command line (shell) access, so that you could browse to the wp-content/ewww/ folder and run 'optipng -v' ?
    2. can you see if Debian is using 64-bit or 32-bit?

  24. serkis
    Member
    Posted 1 year ago #

    1.no shell access
    2. Linux 2.6 Debian Lenny (v5.0) - 32 bit

  25. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    serkis, that might explain why it doesn't work then. Debian 5 is old enough that it probably has an older kernel than centos 5, and thus the bundled tools are incompatible. I wasn't sure anyone was still using Debian 5. At any rate, I'll see if I can setup a VM with that and re-compile the tools.

    andre, I'm still working on my centos6 VM to try and replicate your issue.

  26. andrebazaglia
    Member
    Posted 1 year ago #

    That's okay, nosilver4u! ;)

    You got the same issue in your VM?

  27. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    not yet, just finished installing it. I'll probably work more on it Monday.

  28. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    andre,
    After doing sudo yum install glibc.i686 everything works fine for me on centos6. Can you paste the output of this command:

    ls -l /var/www/html/wp-content/ewww/

  29. andrebazaglia
    Member
    Posted 1 year ago #

    Hi,

    ls -l /var/www/html/wp-content/ewww/ output:

    total 3080
    -rwxr-xr-x 1 apache apache 923929 Jan 18 15:52 gifsicle
    -rwxr-xr-x 1 apache apache 797153 Jan 18 15:52 optipng
    -rw-r--r-- 1 root root 667776 Jan 18 16:22 optipng-mac
    -rw-r--r-- 1 root root 739504 Jan 18 15:55 pngout-static

  30. nosilver4u
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, let's try a test...

    Create a file named test.php and insert this code:

    andre:

    <?php
    echo shell_exec('/var/www/html/wp-content/ewww/optipng -v 2>&1');
    echo "<br>";
    echo shell_exec('/var/www/html/wp-content/ewww/gifsicle --version 2>&1');
    ?>

    serkis:

    <?php
    echo shell_exec('/hermes/bosweb25a/b209/nf.stmarytoronto/public_html/blog/wp-content/ewww/optipng -v 2>&1');
    echo "<br>";
    echo shell_exec('/hermes/bosweb25a/b209/nf.stmarytoronto/public_html/blog/wp-content/ewww/gifsicle --version 2>&1');
    ?>

    If there is any output, please post the url to the test.php file so I can see it for myself.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.