WordPress.org

Ready to get started?Download WordPress

Forums

options.php forbidden (5 posts)

  1. adamwhiles
    Member
    Posted 7 years ago #

    Ok, I have tried to reinstall and redownload and everything I can think of but nothing has worked. When I goto Options->Writing and click the Update Options button I get the following:

    Forbidden

    You don't have permission to access /blog/wp-admin/options.php on this server.
    ApacheR Server at http://www.phpshack.net Port 80

    Not sure what the problem is, hoping I might get a few clues here.

    BTW, I contacted my hosting support and mod_security is enabled, if this is the problem is there a workaround for this?

  2. JeremyVisser
    Member
    Posted 7 years ago #

    Hmm...looks like a permissions issue? Use your FTP client to make sure the UNIX permissions are at least rw-r--r-- (644) or even rwxr-xr-x (755).

    Do other admin pages work?

  3. Tresa
    Member
    Posted 7 years ago #

    No, changing permissions does not work. That was the first thing I tried.

    Other admin pages work just fine (for me); it's only the options that link to options.php that give the 403 error.

  4. Chris_K
    Member
    Posted 7 years ago #

    One option would be to search here in the forums for mod_security and 403 and options. There was quite a long thread last summer that involved some work-arounds.

  5. Tresa
    Member
    Posted 7 years ago #

    I don't have mod_security on. The only way I managed to "fix" the problem was to export my posts from my old install, create a fresh install, and import my old posts (6 years worth - ouch) into it.

    It still required a bit of tinkering with the database, so I wouldn't advise that for anyone who isn't 100% sure of what they're doing.

Topic Closed

This topic has been closed to new replies.

About this Topic