WordPress.org

Ready to get started?Download WordPress

Forums

Exifography
[resolved] options array isn't handled correctly, pre-3.5 dependency (5 posts)

  1. OllieJones
    Member
    Posted 1 year ago #

    Nice.
    But Line 454 needs to be changed from

    if ($options['auto_insert'])

    to

    if (array_key_exists('auto_insert', $options) && $options['auto_insert'])

    Also in Version 3.5+ of WP, they killed off the use of the attachment_fields_to_edit callback you're using.

    Are you willing to take on a co-contributor?

    http://wordpress.org/extend/plugins/thesography/

  2. kristarella
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, I'll look into it.

    I might be willing to have contributors. Do you use GIT at all? I haven't started using it for projects yet, but I have been thinking I should, so that might be a good way to have multiple contributors.

  3. Donncha O Caoimh
    Member
    Posted 1 year ago #

    Another options bugfix - in html_fields() you need to use esc_html() on the value.

  4. Donncha O Caoimh
    Member
    Posted 1 year ago #

    Oh, I forgot to add, thanks for writing the plugin, it's very useful!

  5. kristarella
    Member
    Plugin Author

    Posted 11 months ago #

    I'm finally getting on to these things! I've actually made edits to the trunk...

    Ollie,
    I can't see any evidence that the attachment_fields_to_edit filter has been deprecated. It's not marked at deprecated in the docs and the function get_attachment_fields_to_edit is in the 3.7-alpha code with the filter still in use.

    Donncha,
    Why would I want to escape the HTML in the settings inputs? I want people to be able to type & see plain HTML in those fields. NB I have simple validation in options_validate(). I'm happy to look into it more if you think my validation is not sufficient.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.