WordPress.org

Ready to get started?Download WordPress

Forums

Option form entries being replace by 'a' (6 posts)

  1. lworrilow
    Member
    Posted 7 years ago #

    If I make any changes at all on the option form, other than the default options, after updating options all the text boxes are replaced with the letter 'a' and all check boxes on the bottom of the form are checked. The first time it happened I only entered the word "Footnotes" into the before box.

    I'm using WordPress version 2.2.1. and Copyblogger 1.0 by Chris Pearson.

  2. Plucko
    Member
    Posted 6 years ago #

    I have the same problem. Does anyone know how to fix this? (I'm using WP 2.5). It's been 7 months and no one has replied yet...

  3. Plucko
    Member
    Posted 6 years ago #

    Oh I got an update on this, lworrilow! If you go to the Footnotes page in your Dashboard (Settings > Footnotes) you can remove the a's there and it seems to work after removing the a's. Although I don't understand what the a's were doing there in the first place...

  4. Plucko
    Member
    Posted 6 years ago #

    Never mind, when I re-submit the form I continue to have the same problem. There seems to be a problem with re-submitting the form because everything resets to normal after that (which means it doesn't work).

  5. frame25
    Member
    Posted 6 years ago #

    Everyone who installs and uses this plugin should read and implement this fix.

    Many people are having a problem where after updating the Options for this plugin, it breaks and they get weird "a" characters instead of the proper footnotes.

    I found the problem and fixed it. When using a special HTML character like the default one (the one suggested right there on the options page, [ampersand]#8617;) it is RENDERED as the special character the next time the options page loads, and when you RE-SAVE THE OPTIONS, THAT IS WHEN IT BREAKS.

    Developers can test this:

    1) Go to the options page in a default installation
    2) If the Backlink character is displayed as "[ampersand]#8617;" then click Update Options and proceed to step 3; otherwise:
    3) Notice that the Backlink character is RENDERED as the little back arrow instead of being the HTML code for it!

    (Note that I had to use "[ampersand]" instead of the actual symbol in this post here; WordPress.org forums converts it to the arrow character too, making it harder to illustrate the problem! Ironic.)

    Now the next time you click "Update Options" it BREAKS the settings and leads to everything being a jumble of "a" and so on. Apparently trying to save the ACTUAL character in the database, instead of the code for it, causes it to choke.

    SOLUTION:

    On line 71 of admin_panel.php in the wp-content/plugins/wp-footnotes directory of your site, change the code currently as:

    <?php echo $wp_footnotes_current_settings['backlink']; ?>

    to:

    <?php echo htmlspecialchars($wp_footnotes_current_settings['backlink']); ?>

    Fixed!

  6. jaclynmarie1
    Member
    Posted 6 years ago #

    I actually have that problem too, AND even if I reset to original settings. My superscript is displayed in the same size as the rest of the text.

Topic Closed

This topic has been closed to new replies.

About this Topic