WordPress.org

Ready to get started?Download WordPress

Forums

WP-Optimize
[resolved] Optimized OK but DB is still the same size (8 posts)

  1. Dave333
    Member
    Posted 1 year ago #

    I ran the WP Optimize plugin and it said that it had successfully optimized all the tables but there has been no reduction in the size of the database.

    wp_commentmeta, for example, is still 354 mb.

    Any ideas how to get the optimisation to actually reduce the size of the database would be appreciated.

    Thanks.

    http://wordpress.org/extend/plugins/wp-optimize/

  2. Dave333
    Member
    Posted 1 year ago #

    I figured it out. You have to run a query in PHPMyAdmin to removed them:

    DELETE FROM wp_posts WHERE post_type = "revision";

    This makes this plugin basically redundant as you might as well do the optimising of the DB first while you are in PHPMyAdmin.

    Here is some additional info on reducing your DB size that helped me:
    http://www.wpbeginner.com/wp-tutorials/how-to-disable-post-revisions-in-wordpress-and-reduce-database-size/

  3. jamescampbell9
    Member
    Posted 1 year ago #

    I dunno Dave, that sounds pretty risky going into phpadmin and deleting files. I hope you had a back up saved. I was stumped on how to figure out how big my database was. Everyone talks about thier database size like its so easy to find out. When you download Wp Optimized when you click on the wp-optimize in the admin panel, it tells you your database size at the bottom of the page!! Wow so easy. When I optimized my database size didn't change either even though it said the process was completed successfully. I click on some other button like post or admin or whatever other screen and then clicked BACK on WP-Optimize and the database size refreshed and it was now the lower amount. I don't think you needed to do that PHP Admin step but maybe I'm wrong

  4. Vernon Fowler
    Member
    Posted 1 year ago #

    As with James, when I visited another admin screen and returned to a refreshed WP-Optimize screen, the report showed a significant decrease in my database size.

  5. ruhanirabin
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin actually executes what @Dave said .. so I am unable to replicate this problem.

    The reason of creating this plugin is to avoid going inside phpMyAdmin.

  6. montepente
    Member
    Posted 1 year ago #

    I'm experiencing the same problem here. I'm using WordPress 3.5.2 with the version 0.9.4 of the plugin.

    At first, it says my tables need to be optimized. When i check the optimization checkbox and the process, it seems to do something. After a moment, it says my database has been optimized, every table have the notice that says they were optimized too.

    But when i load the page again, by going in the WP Optimize tab, a notice by each tables says it still need to be optimized. The database is also the same size, nothing has changed.

    So basically, it says it works, but it does not seem like it does anything at all for me. I get no error or anything.

  7. ruhanirabin
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Montepente, please note the database size before and after the optimization. there might be interface related issues.. but if the plugin performed an optimization. your db size should be different (unless there is nothing to optimize)

  8. ruhanirabin
    Member
    Plugin Author

    Posted 10 months ago #

    @montepente, BTW I just get to know that some shared server does not allow executing the OPTIMIZE sql command on their DB, that could create the exact problem you have been saying.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic