WordPress.org

Ready to get started?Download WordPress

Forums

Spun
[resolved] [closed] Optimization for other browsers (10 posts)

  1. Seminko
    Member
    Posted 10 months ago #

    Hey guys, I was wondering if there is an optimized version of Spun out there. Or, if someone could help me with that (if possible that is).

    Unfortunately, all three main browsers display the page in a completely different way. The worst of them is Firefox where the circles are totally invisible until hovered over.

    Chrome (imgur.com)
    Internet Explorer (imgur.com)
    Firefox (imgur.com)

    I really like Spun but this really shuts down this project as most of the business ppl here in the Czech Rep use IE and Firefox :-/

    Thank you

  2. Andrew
    Forum Moderator
    Posted 10 months ago #

    Can you try out the Spun demo site and see if the issues persist?

  3. Seminko
    Member
    Posted 10 months ago #

    Hey Andrew,

    just tried. It still has its flaws:
    Firefox - there is a slight shift of the picture on mouseover
    IE - the pictures do not go from black and white to color but rather from a less saturated image to full saturation but are colored in both positions

    But such discrepancies are not THAT crucial. I could live with those...

  4. Andrew
    Forum Moderator
    Posted 10 months ago #

    The IE issue is more difficult to fix because it's an issue with IE not supporting the CSS3 grayscale style. Firefox does not even fully support it.

    There is a JavaScript library you could use to resolve the IE issue, http://www.pixastic.com/lib/docs/actions/desaturate/ , but it may be a bit overkill for something that's only aesthetically affecting your site.

  5. Seminko
    Member
    Posted 10 months ago #

    Thank you for the explanation. Sure the IE issue (lack of grayscale) is not a problem but how to fix the Firefox issue? I mean the demo site you posted works fine (the circles are visible). Is there an easy-ish fix for that? Obliged!

  6. Andrew
    Forum Moderator
    Posted 10 months ago #

    Could you link to your site? It could be something to do with your server settings, or that you're missing a file on your site.

  7. Seminko
    Member
    Posted 10 months ago #

  8. Andrew
    Forum Moderator
    Posted 10 months ago #

    Firefox needs to load the "desaturate.svg" file in the theme's "inc" folder, but your server isn't allowing it as seen when you visit the file:
    http://a-zeman.cz/wp-content/themes/spun/inc/desaturate.svg#greyscale

    Can you talk to your hosting providers about this?

  9. Seminko
    Member
    Posted 10 months ago #

    Will definately try and get back to you. Thank you

  10. Seminko
    Member
    Posted 10 months ago #

    Awesome! There was this cool guy who helped me create a web.config and the problem got solved.

    I pasted it here so everyone with a similar problem could see it:

    <configuration>
        <system.webServer>
    
         <staticContent>
                <mimeMap fileExtension=".svg" mimeType="image/svg+xml" />
         </staticContent>
    
        </system.webServer>
    </configuration>

    Thank you again Andrew for your brilliant support!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic