WordPress.org

Ready to get started?Download WordPress

Forums

Openid problems with WordPress 2,8 (14 posts)

  1. PoloniculMov
    Member
    Posted 5 years ago #

    I updated to 2.8 and i have some problems with openid.
    1. if i supply a non-valid site or a non-openid enabled site i get a white-screen with a curl error.
    2. if i supply an openid-enabled url i get a white screen saying:
    Successfully fetched 'http://*******.com/': GET response code 200
    Cannot map "http://axschema.org/contact/email" because previous mapping exists
    Cannot map "http://axschema.org/namePerson" because previous mapping exists
    Cannot map "http://axschema.org/namePerson" because previous mapping exists
    3. The Openid logo and the helper text are no longer displayed on the comments.

  2. WraithKenny
    Member
    Posted 5 years ago #

    After activating the plugin, and before doing anything else, check to if see the Dashboard and/or General Settings pages break.

  3. PoloniculMov
    Member
    Posted 5 years ago #

    Everything else works with the plugin activated.

  4. ioni
    Member
    Posted 5 years ago #

    And what about 'no Mode Set'

  5. synth01
    Member
    Posted 5 years ago #

    I have a similar problem, only I just barely started using openID on my blog. Haven't seen any administrator page problems, though I am stumped over the lack of openID integration in the comments form even though I'm using the Kubrick theme's comments.php file.

  6. factoryjoe
    Member
    Posted 5 years ago #

    @synth01: See this thread: http://wordpress.org/support/topic/282369

    @PoloniculMov: What theme are you using? And, are you entering the URL on the WordPress login form?

  7. PoloniculMov
    Member
    Posted 5 years ago #

    I'm using the WP soul theme and the problem is with the comments form.

  8. ioni
    Member
    Posted 5 years ago #

    Just out of curiosity I made a new WP2.8 blog (default theme) with just OpenID plugin installed. Nope; not working - 'invalid openid.mode'

  9. davidcollantes
    Member
    Posted 4 years ago #

    @factoryjoe: how seeing "this thread" (http://wordpress.org/support/topic/282369) is going to fix anything? They might be some tips there, but for the regular Joe running a WP 2.8, wanting OpenID means nothing.

  10. brianwhite
    Member
    Posted 4 years ago #

    I updated this plugin to work with WordPress 2.8. See my comment on this thread: http://wordpress.org/support/topic/282369. I would be glad to post my changes for everyone but there doesn't seem to be a way to attach a zip file. If anyone still uses this plugin and is interested I'll upload them someplace and post a link.

  11. davidcollantes
    Member
    Posted 4 years ago #

    @brianwhite, could you please zip and upload somewhere the changed files? I would really like to get this working, as it seems the developers are busy working on better and greater things. Thanks!

  12. alexkhv
    Member
    Posted 4 years ago #

    @brianwhite, you can use any file sharing resource like rapidshare.com or zip it and send to me (alex(at)khv.me), I will share it.

  13. davidcollantes
    Member
    Posted 4 years ago #

    WP-Openid 3.3 fixes the problems. Hurray!

  14. cmanon
    Member
    Posted 4 years ago #

    @davidcollantes I'm using 2.8.6 and it is not working to me with openid 3.3.2, which version of wordpress are you using?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags