WordPress.org

Ready to get started?Download WordPress

Forums

OpenID
OpenID plugin cannot comment on Blogger/Blogspot (3 posts)

  1. angryoldfatman
    Member
    Posted 3 years ago #

    I have resolved most of my problems with the OpenID plugin and WordPress 3.0.1 by changing my webhost to run PHP 5 instead of PHP 4 (a Herculean feat if you happen to be on Yahoo Small Business webhosting, by the way).

    Two major unresolved problems with the plugin remain, both related to making my blog an OpenID provider rather than just allowing OpenID comments on my blog. In other words, using my blog's Internet address as an OpenID for posting comments on other people's blogs.

    Problem #1: The instructions that display in WordPress on how to use the web address (URL) outright lie (emphasis added):

    Blog Owner
    Authorized accounts on this blog can use their author URL (i.e. http://quackingalone.com/blog/author/administrator/) as an OpenID. The Blog Owner will be able to use the blog address (http://quackingalone.com/blog/) as their OpenID. If this is a single-user blog, you should set this to your account.

    Note where I've emphasized the instructions. It is a lie. I have tried many times to post comments using http://quackingalone.com/blog/author/angryoldfatman and it has never, ever worked.

    The blog owner stuff works, I will admit. NOT the blog author account stuff though.

    Perhaps I am specifying the URL wrong, or perhaps I should not be choosing a blog owner in the drop-down list, hell if I know. What would be nice is if the instructions were more clear on this. When providing an example in documentation, SHOW WHERE THE USER NAME GOES. When there is a choice that's going to gum up the works, TELL THE USER WHAT THAT CHOICE WILL PROHIBIT. When there's a particular version of a language or code base or library that is necessary to run your programming, TELL THE USER IN A PROMINENT PLACE THEY MUST HAVE IT. You know, simple, common sense stuff that code monkeys never remember to do.

    Problem #2: NONE... let me repeat for effect... NONE of this plugin works for commenting on Blogger (or Blogspot or whatever the hell it's called). The part that works on other sites, the blog owner URL, does NOT work on Blogger commenting. You get this wonderful message instead:

    Your OpenID credentials could not be verified.

    Absolute garbage. Unacceptable. I know that it's probably Google (or whoever owns that God-forsaken Blogger junk now) that's screwing up the OpenID standards with regards to retrieving the data, but come on. I've had to program around other stupid programmers before, so I know this could probably be fixed if some effort was applied.

    Now that I've learned at least one of the coders who wrote this plugin has been hired by Google, maybe he can fix their crap to actually comply with the OpenID standard, or at least see how they parse the data so he can put a workaround in the plugin.

  2. topdownjimmy
    Member
    Posted 3 years ago #

    This message is the result of an incompatibility with WP Super Cache.

    Two steps to get OpenID working again with WP Super Cache:

    1. Add /openid/ to the URL exclude string list (in the "Advanced" tab of WP Super Cache settings)
    2. Click "Delete Cache" in the "Contents" tab

    That should do it.

  3. topdownjimmy
    Member
    Posted 3 years ago #

    3. Disabling the included XRDS-Simple plugin may also be necessary.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic