WordPress.org

Ready to get started?Download WordPress

Forums

OpenID field hidden under comment text area (8 posts)

  1. Laplandia
    Member
    Posted 3 years ago #

    Hi there.

    I'm using latest versions of WordPress and OpenID plugin. But users can't use OpenID to comment as OpenID fields are hidden by text area. I can see it in html, but I can't see it on site. Is there a way to solve the problem?

    I've already tried several themes. I've also tried to edit OpenID plugin, but I still don't know how to move the fields it adds to the comments form.

  2. slavach
    Member
    Posted 3 years ago #

    Here is a quick and dirty fix for OpenID plugin. I cropped the javascripts code. Now, openid field is always visible. Not outstanding, but it works at least.

    Here is the patch for OpenID

  3. derekbeck
    Member
    Posted 3 years ago #

    Where do you patch this? do I append the code to the javascript.js, or replace it with yours?

    I don't know if I have the same problem... i don't see any openid in my comments, though I have it enabled ( see http://www.derekbeck.com/1775/ )

    I'm using this plugin:
    http://wordpress.org/extend/plugins/openid/

    Thanks,
    Derek

  4. slavach
    Member
    Posted 3 years ago #

    This is a diff file. It should be applied by the patch utility, which is included to any Linux. If you don't have the patch utility (Windows user for example), you could replace the file wp-content/plugins/openid/f/openid.js with this one: http://slavach.info/wp-content/plugins/openid/f/openid.js

    I'm not sure that your problem is the same, as far as the openid checkbox is present at your page. In my case, this field hadn't been visible, until I edited the openid.js.

  5. Allpa
    Member
    Posted 3 years ago #

    slavach, с Вашим хаком появилось ранее скрытое поле плагина - спасибо! :)

    Одно "но": на скриншотах чекбокс "Authenticate this comment using OpenID" логично находится под полем "Веб-сайт", а у меня в блоге (здесь, к примеру, можно посмотреть) - рядом с ним (скриншот). Что, имхо, некрасиво смотрится. Это я сейчас ещё укоротила надпись до "С помощью OpenID", а если написать полностью: "Аутентификация с помощью OpenID", то строчка вообще разбивается на две, что совсем ужос-ужос :(
    Я вижу, Вы специалист отменный, - не могли бы Вы подсказать, где подпилить, чтобы?

    Огромное спасибо ещё раз :))

  6. slavach
    Member
    Posted 3 years ago #

    You could change the 'display' property of the #openid_comment to 'block'. Look into the file wp-content/plugins/openid/f/openid.css:

    #openid_comment {
      margin: 0.8em 1em;
      display: block; /* add this */
    }
  7. Allpa
    Member
    Posted 3 years ago #

    slavach, супер!
    Я вчера, ожидая Вашего ответа, экспериментировала и просто изменила "1em" на "20em", в результате чего строчка сдвинулась вниз.
    Но Ваш вариант, конечно же, правильнее, - низкий Вам поклон, дорогой мой, за неоценимую помощь :)

  8. cobain
    Member
    Posted 3 years ago #

    Don't use dirty hack from slavach. It's doesn't work)

    There is a bug in plugin (OpenID v3.3.3) in file wp-content/plugins/openid/common.php on line 543.

    Replace

    echo '{ valid:' . ( is_url_openid( $_REQUEST['url'] ) ? 'true' : 'false' ) . ', nonce:"' . wp_create_nonce('openid_ajax') . '" }';

    with

    echo '{ "valid":' . ( is_url_openid( $_REQUEST['url'] ) ? 'true' : 'false' ) . ', "nonce":"' . wp_create_nonce('openid_ajax') . '" }';

    Проще говоря, патч который привёл товарищ выше, просто статично отображает поле для ID. Но на самом деле ошибка была в самом плагине, который неверное формировал json ajax ответ и поэтому введённый OpenID URL не признавался валидным и поле не появлялось.

Topic Closed

This topic has been closed to new replies.

About this Topic