WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Facebook: Advanced Sharing Optimization for All Social Websites
[resolved] opengraph tag og:image - image not showing when posting on Facebook (9 posts)

  1. labit
    Member
    Posted 1 year ago #

    Hi there,

    when posting articles from our WordPress blog tvnoir.de on the Facebook timeline preview images are not shown anymore.

    The error occurred about three weeks ago, we can't determine the exact point of time. Now even when we're reposting older posts, which had been published on Facebook before with working preview image, the preview image specified in the open graph meta tags is not appearing in the Facebook post. When the article is shared on Google+ the correct preview image is shown.

    I tried various ways to determine the cause for this. The Facebook Debugger shows the message: "Object at URL 'http://tvnoir.de/premiere-alin-coen-band/' of type 'article' is invalid because the given value '' for property 'og:image:url' could not be parsed as type 'url'." (https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Ftvnoir.de%2Fpremiere-alin-coen-band%2F). But I can't see the reason for this error, the source code seems to be fine.

    So if somebody has a hint for me where to problem could originate I would absolutely glad!

    Thank you in advance

    Lukas

    http://wordpress.org/extend/plugins/nextgen-facebook/

  2. labit
    Member
    Posted 1 year ago #

    Update: I added a fix for the URL error in FB debugger and that's sorted now. The debugger shows the correct output and I ould identify the culprit: it's the image size.
    If I post the preview image form youtube directly, there's also now preview image in the FB post. So how can I change the image size of the image nextgen facebook puts in og:image?

  3. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Well, there are a few issues here...

    Yesterday you had two og:image tags -- one was from another plugin or template, and the other was from NGFB. The NGFB one was blank because no image was found in your content.

    I noticed you use an <embed> tag for your videos instead of an <iframe>. NGFB was just checking for iframes, but I've added support for embeds in v3.5.2. You can download the current DEV version here: http://downloads.wordpress.org/plugin/nextgen-facebook.zip

    NGFB should now detect your video and add the appropriate preview image as well.

    The blank og:image meta tag may, or may not, be desirable, depending on the behavior you want. If there are no images in your content, a blank og:image meta tag might prevent FB (and others) from choosing a random image from your page (sidebar, etc). On the other hand, the FB debugger doesn't seem to like it. ;-)

    You can uncheck the "Include Empty og:* Meta Tags" option on the settings page to exclude that empty og:image meta tag.

    js.

  4. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    For the image size used in the og:image meta tag, have a look at the "Image Size Name" option on the NGFB settings page.

    js.

  5. labit
    Member
    Posted 1 year ago #

    Thank you for the fast reaction, I'm seriously impressed. I will update your plugin asap.
    I found a workaround in the meantime (I'm not a pro when it comes to PHP coding so have patience with me): The other og:image tag is created by smart youtube pro. It automatically selects the default.jpg from ytimg.com and inserts that into the tag. I changed the code to select 0.jpg (for example http://i.ytimg.com/vi/zjg-QJc3r10/0.jpg) and now Facebook fetches the thumbnail.

    Facebook seems to have changed the minimum size for thumbnails to at least 200x200px in the last weeks, as we didn't have that problem before.

    Again thank you for your assistance, is there a way to donate to your work?

    cheers

    Lukas

  6. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Lukas,

    Thanks. There's a donate button on the NGFB settings page.

    Let me know how that DEV version works out for you. When viewing your page HTML source, you should see some og:video meta tags, as well as an og:image tag with the preview image.

    Thanks,

    js.

  7. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Lukas,

    Let me know how that DEV version works out. ;-)

    js.

  8. labit
    Member
    Posted 1 year ago #

    Hi js,

    sorry for the long delay, we underwent major changes on the website so it took some time. I saw that you released version 3.6.2, are the changes included there?

    Thank you for your time and patience!

  9. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Yup. ;-)

    js.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic