WordPress.org

Ready to get started?Download WordPress

Forums

Custom Community
open_basedir restriction in effect. File(../../../../../wp-load.php) (1 post)

  1. SiteDesignUSA
    Member
    Posted 11 months ago #

    Hi and thanks for the plugin.

    I upgraded to wp 3.6 today and started seeing these php errors.

    open_basedir restriction in effect. File(../../../../../wp-load.php) is not within the allowed path(s):

    Centos 6.4, php-fpm 5.3, nginx 1.4 is the setup.

    I'm using Mark Jaquith's WP stack etc so my plugin folder is above the wp folder where wp-load.php is.

    I set these in the wp-config.php file so,

    !defined('WP_SITEURL') && define('WP_SITEURL', 'http://'.$_SERVER['SERVER_NAME']. '/');
    
    /**
     * WP_HOME is another wp-config.php option added in WordPress Version 2.2. Similar to WP_SITEURL,
     * WP_HOME overrides the wp_options table value for home but does not change it permanently.
     * home is the address you want people to type in their browser to reach your WordPress blog. It should include the http:// part. Also, do not put a slash "/" at the end.
     */
    !defined('WP_HOME') && define('WP_HOME', WP_SITEURL);
    
    /** no trailing slash, full paths only */
    !defined('WP_CONTENT_DIR') && define( 'WP_CONTENT_DIR', dirname( __FILE__ ) . '/content' );
    
    // full url - WP_CONTENT_DIR is defined further up
    !defined('WP_CONTENT_URL') && define( 'WP_CONTENT_URL', WP_SITEURL . 'content');
    
    /** Allows for the plugins directory to be moved from the default location. @since 2.6.0 */
    // full path, no trailing slash
    !defined('WP_PLUGIN_DIR') && define( 'WP_PLUGIN_DIR', WP_CONTENT_DIR . '/plugins' );
    
    /** Allows for the plugins directory to be moved from the default location. @since 2.6.0 */
    // full url, no trailing slash
    !defined('WP_PLUGIN_URL') && define( 'WP_PLUGIN_URL', WP_CONTENT_URL . '/plugins' );
    
    /** Allows for the plugins directory to be moved from the default location. @since 2.1.0 */
    // Relative to ABSPATH.  For back compat.
    !defined('PLUGINDIR') && define( 'PLUGINDIR', WP_CONTENT_DIR . '/plugins' );

    (../../../../../wp-load.php) is in the width-calculators.php file line 4

    I am trying
    $loader = ABSPATH . 'wp-load.php';

    but haven't tested. Just wanted to give you a "heads up" about it.

    I'll post if it fixes for me.

    Thanks.

Reply

You must log in to post.

About this Theme

About this Topic