WordPress.org

Ready to get started?Download WordPress

Forums

open web analytics install (2 posts)

  1. finid
    Member
    Posted 6 years ago #

    Folks,

    Just came across owa and tried to install as a wp plugin. I can install and activate the package without modifying owa-config.php. But when I click on "admin settings, I get this ( wp-cache was deactivated):

    "Your Account lacks the necessary priviledges to access the requested
    resource."

    However, when I modify owa-config.php with the correct db info, I get
    these:

    Warning: dbsingleton(/home/liniver/public_html/web2dotoh/wp-content/
    plugins/owa/plugins/db/owa_db_OWA_DB_TYPE.php) [function.dbsingleton]:
    failed to open stream: No such file or directory in /home/linivers/
    public_html/web2dotoh/wp-content/plugins/owa/owa_coreAPI.php on line
    96

    Warning: dbsingleton(/home/liniver/public_html/web2dotoh/wp-content/
    plugins/owa/plugins/db/owa_db_OWA_DB_TYPE.php) [function.dbsingleton]:
    failed to open stream: No such file or directory in /home/linivers/
    public_html/web2dotoh/wp-content/plugins/owa/owa_coreAPI.php on line
    96

    Warning: dbsingleton() [function.include]: Failed opening '/home/
    liniver/public_html/web2dotoh/wp-content/plugins/owa/plugins/db/
    owa_db_OWA_DB_TYPE.php' for inclusion (include_path='.:/usr/lib/php:/
    usr/local/lib/php:/home/linivers/public_html/web2dotoh/wp-content/
    plugins/UltimateTagWarrior:/home/linivers/public_html/web2dotoh/wp-
    content/plugins/UltimateTagWarrior') in /home/liniver/public_html/
    web2dotoh/wp-content/plugins/owa/owa_coreAPI.php on line 96

    Fatal error: Call to a member function on a non-object in /home/
    liniver/public_html/web2dotoh/wp-content/plugins/owa/owa_coreAPI.php
    on line 97.

    I've searched and googled for related or similar issues, but have so far come up with nothing.

    Even In stand alone mode, I get these when I navigate to the install page:

    Warning: factory(/home/liniver/public_html/owa/modules/base/install//
    install_base_OWA_DB_TYPE.php) [function.factory]: failed to open
    stream: No such file or directory in /home/linivers/public_html/owa/
    owa_lib.php on line 410

    Warning: factory() [function.include]: Failed opening '/home/liniver/
    public_html/owa/modules/base/install//install_base_OWA_DB_TYPE.php'
    for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /
    home/linivers/public_html/owa/owa_lib.php on line 410

    Fatal error: Call to undefined function: checkforschema() in /home/
    liniver/public_html/owa/modules/base/installStart.php on line 51

    Can't figure out anything from these errors. Any help you can render will be appreciated

    Thanks

  2. whooami
    Member
    Posted 6 years ago #

    those errors are a result of certain files (the file names are listed in the error strings) not being where it expects (whatever IT is)

    For instance:

    Failed opening '/home/
    liniver/public_html/web2dotoh/wp-content/plugins/owa/plugins/db/
    owa_db_OWA_DB_TYPE.php' for inclusion

    Its looking for a file named owa_db_OWA_DB_TYPE.php at this location:

    /home/
    liniver/public_html/web2dotoh/wp-content/plugins/owa/plugins/db/
    owa_db_OWA_DB_TYPE.php

    I not going to debug all those errors, since Ive downloaded the package and looked at it.. (ugh, can I say NO loud enough??)

    Suffice to say they appear to all be related to the paths.

    If you think you have uploaded the files correctly, and shouldnt be seeing those errors, it's probably best to contact the guy/girl at that site -- there's a blog there after all :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags