WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Open Graph Just Can't Be Disabled (5 posts)

  1. tqueiroz
    Member
    Posted 11 months ago #

    Hi guys,

    Can you help me out here? My WP blog has been working fine until a couple days ago, then I start getting duplicate OG tag errors in Facebook.

    I've always let OG tags disabled on WordPress SEO because I prefer to let other plugin (Add Link to Facebook) do it, and it's been working fine since then.

    But now, it just stopped working. I've tried checking/unchecking again the "Add Open Graph meta data" option, cleaning up cache, disabling WP Super Cache plugin, everything, but the only time I stop getting errors is when I disable WordPress SEO plugin.

    When I reenable, I start getting errors again.

    Does anybody know how to effectively disable OG tags in WordPress SEO plugin?

    Thanks in advance!

    http://wordpress.org/plugins/wordpress-seo/

  2. tqueiroz
    Member
    Posted 11 months ago #

    Just to add, I have tried this on versions 1.4.15, 1.4.14 and 1.4.13.

    ======== EDIT

    I have just set all settings back to default and reconfigured everything, using the very same settings. It's working now :)

  3. Marcel Bokhorst
    Member
    Posted 11 months ago #

    You will have to find the plugin (or maybe the theme) that also outputs OGP meta tags. Add Link to Facebook outputs the correct tags and there were no changes in the recent versions.

    For your next support question or follow up on this question, please go here: http://forum.faircode.eu/

  4. tqueiroz
    Member
    Posted 11 months ago #

    Thanks Marcel, it was actually a problem with WordPress SEO plugin :)

  5. JS Morisset
    Member
    Posted 8 months ago #

    I had a customer with the same issue recently - couldn't disable the WordPress SEO by Yoast Open Graph meta tags (unchecking the option didn't work). Try adding the following to your functions.php file:

    global $wpseo_og, $wpseo_twitter;
    remove_action( 'wpseo_head', array( $wpseo_og, 'opengraph' ), 30 );
    remove_action( 'wpseo_head', array( $wpseo_twitter, 'twitter' ), 40 );

    Worked for me. ;-)

    js.

Reply

You must log in to post.

About this Plugin

About this Topic