WordPress.org

Ready to get started?Download WordPress

Forums

Opacity (14 posts)

  1. piginzen
    Member
    Posted 8 years ago #

    Does anyone know the trick to get opacity to work in IE? Seems to work fine in Opera and Firefox. But IE (as always) drives me up the wall.

    I've tried everything and can't figure it out.

    Thanks.

  2. Jack
    Member
    Posted 8 years ago #

    I thought there was no reliable trick. You could wait for IE 7?

  3. masquerade
    Member
    Posted 8 years ago #

    The only way is to use IE specific filters like filter: alpha(Opacity=10); in the CSS

  4. piginzen
    Member
    Posted 8 years ago #

    Actually, I got it work. At least half way. But my hovers wont change the opacity to another setting.

    Strange.

  5. piginzen
    Member
    Posted 8 years ago #

    By the way, this is my CSS:

    .randomgallery a img {
    border: 1px solid #999;
    background-color: #FFF;
    padding: 4px;
    margin-top: 3px;
    max-width: 75px;
    max-height: 75px;
    height: 75px;
    width: 75px;
    filter: alpha(opacity=50);
    opacity:0.50;
    -moz-opacity:0.50;
    overflow: hidden;
    }
    .randomgallery a img:hover {
    max-width: 75px;
    max-height: 75px;
    height: 75px;
    width: 75px;
    filter: alpha(opacity=100);
    opacity:1.00;
    -moz-opacity:1.00;
    border: 1px solid #999;
    background-color: #2277DD;
    }

  6. Jack
    Member
    Posted 8 years ago #

    HA! Never knew that. But now I do :).
    Works nice for the rollovers, except for the larger images inside the post which change rather slow.

  7. _erik_
    Member
    Posted 8 years ago #

    this won't validate and where exactly it doesn't work? (browser?)
    maybe for safety change 1.00 into 0.99 (just a guessin' idea)
    mfg erik

  8. piginzen
    Member
    Posted 8 years ago #

    tried .99 - same deal.

    at this point, validation is not my concern.

    it's not working in IE6 for PC.

  9. _erik_
    Member
    Posted 8 years ago #

    didnt see it right away: in your css:

    a img:hover

    is something ie don't understand change it into a:hover img then it works (if the image really is a link) so you should disable the 0.5 rule for non-linked images by adding something like:
    * img {filter: alpha(opacity=100);} in order to have in-post images "normal" for ie.
    kind regards

  10. piginzen
    Member
    Posted 8 years ago #

    it's definately not a link.

    hmmm, i guess it will just not work IE... and will just use the IE CSS: _filter: alpha(opacity=100);

    thanks everyone.

  11. masquerade
    Member
    Posted 8 years ago #

    Actually, there isn't much of a way to get a child to have a normal opacity in IE, the children's opacities are relative.

  12. Marc
    Member
    Posted 8 years ago #

    Check here for some opacity tips:

    http://www.mandarindesign.com/blogger.html

    Also check the link in the sidebar under "Popular."

  13. _erik_
    Member
    Posted 8 years ago #

    with me its workin in IE the way explained see (sidebar-img)-->

  14. piginzen
    Member
    Posted 8 years ago #

    Nice! It does work... But I couldnt get it to work with out an anchor...

    No big deal.

    Thanks everyone.

    PS. Erik - i love your new theme!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags