WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Oops (4 posts)

  1. Baileyph
    Member
    Posted 3 years ago #

    I was trying to fix my image in blog posts issue and this started showing up when I tried to see my blog:

    Parse error: syntax error, unexpected '?' in /home/jacirv2/willsreport.com/wp-content/themes/fusion/index.php on line 12

    This is what line 12 looks like in my index.php template

    <div id="post-<?php the_ID(); ?>" <?php post_class(); ?>>

    I have tried removing and replacing every ? on line 12 to try and fix it, but no luck. Anyone see what's wrong?

  2. It may not actually be line 12, alas. Do you have a backup to restore from?

  3. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    the trigger of this error could be in the lines before line 12.

  4. Baileyph
    Member
    Posted 3 years ago #

    Ohmygosh. No backup. I did however, find a double question mark in line 6 and that fixed it. Lesson learned.

    Either of you have any idea where to find the section:
    <?php the_excerpt();?> O_o. I am trying to find it and replace it with <?php the_content();?> to fix an issue I having with uploaded images not showing up in my blog posts (as per instructions from esmi)

    I have looked in index.php template, but cannot find it anywhere.

    Thanks for the tip about the problem not necessarily being on line 12 though.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.