WordPress.org

Ready to get started?Download WordPress

Forums

Onswipe
Doesn't work for pictures ? (14 posts)

  1. attilaphoto
    Member
    Posted 3 years ago #

    I'm happy to finally see this plugin live, however it doesn't seem to work properly for me. One of my self-hosted blogs is a photo blog, just 1 or a few pictures per post and some subtitles.
    On the iPad the splash image looks fine when i'm starting from home screen. The cover icon and the title is OK, but instead of a cover image just a strange blue stripe comes in and out of the screen on the left hand side.
    And then on the post pages (the magazine layout, not the individual posts) no thumbnails or images showing only title headers and the text parts of the posts.
    On one of my test installations I had to create the thumbs-cache folder manually, on another one it's been created automatically, I set permissions to 777 but still no thumbs.
    Any thoughts, similar issues?
    Thanks

    http://wordpress.org/extend/plugins/onswipe/

  2. veddegre
    Member
    Posted 3 years ago #

    I'm having the same problem with my site (chronicles.vedders.com). I get the titles for all of my posts in magazine view (and some text), but no images load. I created the thumbs-cache folder and still no luck. This has some great potential, but without the images, the majority of my content is not viewable from the layout.

  3. ronchalice
    Member
    Posted 3 years ago #

    same problem, no images.

  4. litlnemo
    Member
    Posted 3 years ago #

    Same problem here. The cover logo shows but no other images.

    Plus, now I realize that it doesn't seem to have a way to show the site's ads, so I guess it's not going to work for me anyway.

  5. Thomas Umstattd
    Member
    Posted 3 years ago #

    Same problem here.

  6. troutc
    Member
    Posted 3 years ago #

    Ditto. Come on....it works fine when I use it on my .wordpress site. Wonder what's the difference?

  7. akaalvin
    Member
    Posted 3 years ago #

    yep, no images here either. what's the deal? Any clue?

  8. barbbowman
    Member
    Posted 3 years ago #

    Apparently this involves featured images. http://wordpress.org/extend/plugins/auto-post-thumbnail/ will help (but it does add a thumbnail to each post). Or you can manualky add a featured image to each post. This plugin is supposed to also add this to existing posts, but that did not work for me.

    I cannot get a static launch page to work no matter what I do, it displays the featured immage from the most recent post.

    I'm using Windows Server 2008R2 which OnSwipe has said repeatedly they do not support.

  9. websynergy
    Member
    Posted 2 years ago #

    Working on this for a client and have found this:

    I've tracked down what seems to be the issue with the images not showing but don't know how to correct it.

    Seems to be when OnSwipe passes the image URL to thumbs.php

    This works:

    http://www.domainname.com/wp-content/plugins/onswipe/framework/thumb/thumb.php?src=/wp-content/uploads/2011/04/dino.jpg&w=430&h=250&zc=1&q=75&fx=0

    This does not:

    http://www.domainname.com/wp-content/plugins/onswipe/framework/thumb/thumb.php?src=http://www.domainname.com/wp-content/uploads/2011/04/dino.jpg&w=430&h=250&zc=1&q=75&fx=0

    The difference being, OnSwipe is passing "http://www.domainname.com" to thumbs.php

    I've emailed support but have not heard back if they know a quick fix.

  10. HerrRau
    Member
    Posted 2 years ago #

    My self-hosted wordpress did not show any pictures either. I don't use the uploads folder for uploads, but another folder. In fact, I had deleted the original uploads folder. But onswipe wants this folder to be there so it can write its pix into a cache folder of its own.

    This may be the problem. After adding a (new) uploads folder in wp-content and making it writeable, the pictures do show up in onswipe. (And onswipe's chace folder is there, too.)

  11. Craig M. Jamieson
    Member
    Posted 2 years ago #

    Same problem here. Too bad. Nice potential but, without images, looks pretty lame:(

  12. sparklette
    Member
    Posted 2 years ago #

    I had the same problem with the plugin, and managed to get this working on http://sparklette.net .

    What I did was to manually create the thumbs cache folder /wp-content/uploads/thumb-cache and give it 777 permissions. Note that the folder name is thumb-cache not thumbs-cache.

  13. lankin
    Member
    Posted 2 years ago #

    It won't work for me. I tried thumb-cache, as well as thumbs-cache, and set permissions to 777.

    The weird thing: I installed it yesterday, and it worked perfectly. (I don't own an iPad, so I use Safari for Win7, and change the user-agent to preview the iPad look of the page.)

    It was perfect, apart from the little nuisance that my images inside a blog post get cropped in a way that is not desirable, but the front page / toc worked just fine. I switched and tried the different themes; everything showed up. Featured images, excerpt, all fine.

    Well not this morning. Now I created those two folders, and still no luck. I also sorted out that it might be a cache problem of Safari. I also tried deactivating/reactivating the plugin, as well as deinstalling and reinstalling it.

    I am clueless. I love the look of Onswipe and I would really like to get it to work. Any help would be really appreciated.

    Oh, my page is self-hosted, and the url is:
    http://www.philippejarousskyfans.com

  14. lankin
    Member
    Posted 2 years ago #

    I think I found the culprit. That it worked perfectly yesterday is still a miracle though.

    If I disable WP Touch, it seems to work fine now. There is still the issue of the images in posts that get cropped in a non-favourable way, but for now I can live with it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags