WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Comments
[resolved] Only working on Chrome not IE, Firefox, Opera or w/e (4 posts)

  1. ImGustavo
    Member
    Posted 1 year ago #

    My plugin of "facebook comments" isn't showing on Internet Explorer, Firefox, Opera, Safari... just only works and its showed with Chrome.

    I try a lot of things but nothing works... I read the tip of @alexmoss (the plugin author) on this topic: http://wordpress.org/support/topic/plugin-facebook-comments-not-working-in-ie?replies=32

    He says, adding this lines the plugin works..

    @alexmoss:

    xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml"
    
    So, the full HTML tag on my site is:
    
    <html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml">

    But my template is in HTML5 and i dont know who put that code in mine... Any can help me?

    My template is this:

    <!DOCTYPE html><!-- HTML 5 -->
    <html <?php language_attributes(); ?>>
    
    <head>
    	<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    <LINK REL="SHORTCUT ICON" HREF="http://www.pablohasel.com.ar/favicon.ico" />
    	<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    
    	<title><?php bloginfo('name'); if(is_home() || is_front_page()) { echo ' - '; bloginfo('description'); } else { wp_title(); } ?></title>
    
    <?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>
    <?php wp_head(); ?>
    </head>
    
    <body <?php body_class(); ?>>
    <div id="wrapper">

    Where have to put, or what have to change to put the lines of @alexmoss ?
    Any can help me please? :(

  2. Alex Moss
    Member
    Plugin Author

    Posted 1 year ago #

    Hey,

    The instructions are slightly more updated on the plugin homepage. Also, you may want to look closely at the instructions on the official page within Facebook.com

  3. ImGustavo
    Member
    Posted 1 year ago #

    Finally i can fix it! Thanks Alex...

    this is how I did it:

    The option Enable XFBML should have inserted the code. It is better to insert this manually straight after <body>. Here's the code (remember to change YOUR APP ID to your app ID:

    <div id="fb-root"></div>
    <script>
    window.fbAsyncInit = function() {

    FB.init({appId: 'your app id', status: true, cookie: true,

    xfbml: true});
    };
    (function() {

    var e = document.createElement('script'); e.async = true;

    e.src = document.location.protocol +

    '//connect.facebook.net/en_US/all.js';

    document.getElementById('fb-root').appendChild(e);
    }());
    </script>

    thanks thanks thanks!

  4. chiragahir
    Member
    Posted 1 year ago #

    Hello,

    What file do I add this code in? I dont see <body> in any of the plugin files! The plugin works on Chrome and Safari but not on Firefox, it shows but I am not able to add comment.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic