WordPress.org

Ready to get started?Download WordPress

Forums

Only WordPress Address URL greyed out -need permanent fix. (6 posts)

  1. samluc
    Member
    Posted 3 years ago #

    My WordPress address in URL (general settings) was greyed out and I needed to add www to it .

    So I followed the method described in:
    http://codex.wordpress.org/Changing_The_Site_URL
    Changing the URL directly in the database
    phpMyAdmin> wp_options> siteurl & Home fields.

    That worked but the problem still exists that the WordPress URL is greyed out (the Site URL is fine and I can edit that in general settings).

    I want to have a permanent fix so both boxes can be edited in general settings since I intend to clone these settings for fast and easy setup of other WordPress blogs and I don’t want to go through this problem everytime.

    I believe the edit wp-config.php method gives me two greyed out boxes
    And the edit functions.php is a temporary method only is that right?

    Thanks for any feedback.

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you checked your wp-config.php file?

  3. samluc
    Member
    Posted 3 years ago #

    I had a look - But not quite sure what to notice.
    According to codex

    This is not necessarily the best fix, it's just hardcoding the values into the site itself. You won't be able to edit them on the General settings page anymore when using this method

    So I didnt pursue this any further.
    I havent had this problem before and i think somehow it is related to loading WordPress using Fantasico (Hostgator)
    What do you think?

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    I've never had this issue on Fantastico installs but it is possible that your host has customised the install to lock the install path down. I'd suggest you contact them and ask them about it.

  5. samluc
    Member
    Posted 3 years ago #

    Thanks for your input esmi - I will ask Hostgator.
    If anyone else has any suggestions they would be vmuch appreciated.

  6. samluc
    Member
    Posted 3 years ago #

    After much much work i found the problem - Yes you guessed it....a plugin called Stray Random Quotes. When it is activated, it greys out the WordPress URL in general settings. Deactivate it and its clear and editable.
    Funny thing is this plugin does not effect the site url in general settings at all - only the wordpress url.
    Live & Learn

Topic Closed

This topic has been closed to new replies.

About this Topic