WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Social Login
[resolved] Only with Chrome! Redirect to white page (3 posts)

  1. CoolTarget
    Member
    Posted 2 months ago #

    I tried a lot of plugins, but this is by far the best. Also with this incredible problem:
    if you go at my test site at http://www.cooltarget.net you can see that social login is good with IE and Firefox...but not in Chrome! With Chrome i have a redirect to a white page, or a neverending "Contacting Google, please wait..." (the latter usually happens when i made a logoff and after a logon with social account, without closing browser).

    I tried a lot of things:
    - enable php errors in php.ini, same result (redirect white page, with no error in browser)
    - disable all plugins
    - used standard wordpress theme
    - use chrome from another pc (different os, different language, different owner)
    - Use diagnostic in WSL (requirements are all OK)

    Maybe this problem is from my web hosting company (is it really possible they have different server-side ways to handle requests based on browser) ? But, in other browsers all is working fine....maybe it is really a WSL problem with Chrome?
    I really can't understand this strange problem.

    I'm asking for support, suggestions, help....because i don't want to leave this plugin, even with this problem it remains the best one, i think.
    I hope someone can help me, i'll do all i can to figure this out.

    I also enable "development mode" in WSL.

    Thanks!

    https://wordpress.org/plugins/wordpress-social-login/

  2. CoolTarget
    Member
    Posted 2 months ago #

    The problem was found, after a heavy troubleshooting.

    I'm using CloudFlare as CDN, and it have a thing called Rocket Loader, but is in beta. If you enable it, you'll have the problem i described. For now i don't test a solution, but i found an interesting article here: http://wp-dreams.com/cloudflare-rocket-loader-for-wordpress/. Maybe i'll try this in the future.

  3. CoolTarget
    Member
    Posted 2 months ago #

    My solution is to simply turn off Rocket Loader on Cloudflare ;)
    In this moment i've no time to test the procedure in the article i found.

Reply

You must log in to post.

About this Plugin

About this Topic