WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow
[resolved] only !slideshow_deploy! displays when i use shortcode with AFC (3 posts)

  1. guddu1315
    Inactive
    Posted 1 year ago #

    Hello i a m adding slideshow shortcode to Advanced custom fields in wysiwyg editor ........

    when i add the shortcode it only displays !slideshow_deploy!
    i took help from this support question

    so basically i need to add content filter in AFC how can i do that??
    any one can help? its urgent

    http://wordpress.org/extend/plugins/slideshow-jquery-image-gallery/

  2. guddu1315
    Inactive
    Posted 1 year ago #

    got the solution
    write this in your FUNCTION.php

    function my_acf_format_value_for_api($value, $post_id, $field){
    	return str_replace( ']]>', ']]>', apply_filters( 'the_content', $value) );
    }
    function my_on_init(){
    	if(!is_admin()){
    		add_filter('acf/format_value_for_api/type=wysiwyg', 'my_acf_format_value_for_api', 10, 3);
    	}
    }
    add_action('init', 'my_on_init');
  3. yanks789
    Member
    Posted 11 months ago #

    I had tried the Advanced Custom Field: Shortcode Field and still had the !slideshow_deploy! displaying. I tried the "Avoid content filter" option on yes and no and it didn't work.

    Thank you so much for supplying the code that needed to be inserted into the function.php file as it worked!!!! Thanks for the help :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic