WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] "Only secure content is displayed" warning bar (13 posts)

  1. JTitgemeyer
    Member
    Posted 1 year ago #

    After activating JetPack, I get the "Only secure content is displayed" warning bar on my site. If I disable JetPack, it goes away. Is there a setting in there that I can change that will prevent this from showing up. I can't use this on a live site like this.

    Thanks,

    John

    http://wordpress.org/extend/plugins/jetpack/

  2. lousywriter13
    Member
    Posted 1 year ago #

    I have had to disable JetPack as well on several sites. Did you find any workaround for this?

  3. lousywriter13
    Member
    Posted 1 year ago #

    Okay, I've been looking into this some more. This morning I re-enabled jetpack on http://www.robdiaz2.com. I then logged out of wordpress. When I navigated to the site as a visitor would, I did not get the only secure content warning.

    Upon logging in, I got the warning again.

    So, it would seem that this has *something* to do with the iFrame involved with the WP login/admin bar.

    I determined this by looking in IE's developer tools application and finding the https iFrame that was loading http content.

    Not sure if this means the problem is really "not an issue" for most users, but it is certainly a major nuisance for those of us admining sites that use this tool.

    Hope this helps you.

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    So, it would seem that this has *something* to do with the iFrame involved with the WP login/admin bar.

    I determined this by looking in IE's developer tools application and finding the https iFrame that was loading http content.

    Thanks for providing these details about your problem, it helps!

    Could you send me a screenshot of the HTTPS iFrame you see in IE's developer tools?

  5. lousywriter13
    Member
    Posted 1 year ago #

    I have uploaded a screenshot here. Not sure if this is specifically what you want, though:

    http://i276.photobucket.com/albums/kk33/robdiaz2/iFrame_jetpack_zps34795139.png

    Is there a better way to get you the image?

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks! This helps a lot!

    I have warned our developers about the issue, and we will have a look at it and see if that can be addressed.

    In the meantime, and to prevent this security notice from appearing in Internet Explorer, you can go to Internet Options > Security > Custom Level, and enable "Display Mixed Content". That should solve your issue.

  7. Robdiaz2
    Member
    Posted 1 year ago #

    Thanks!

    The "trouble" with turning off the option is that it's off for all websites, not just mine.

  8. steve.slatcher
    Member
    Posted 1 year ago #

    I see that this issue has been marked "resolved". Does that mean a fix should be available?

    I have literally just downloaded a new version (2.1.1) and I see the problem. Indeed, I only just noticed it after the last download.

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @Steve You can solve this issue by changing your Internet Explorer Options, as I mentioned above.

    We are also looking into this problem, in order to see if this can be addressed in a future Jetpack update.

  10. yosemitetracks
    Member
    Posted 1 year ago #

    I know that this is a small(ish) issue, but I don't really see that disabling a warning message that exists for a valid reason is a very good solution to the issue.

    The warning is annoying as all get up, as it requires me to move the mouse and touch the keyboard - not user friendly. I appears all of the time. And, it is a message that indicates that there might be a security risk- perhaps not here, but in other sites, so disoabling it everywhere is very bad security.

    I (for one) would really appreciate it if this was addressed.

    Thanks,

    Jeff

  11. tiger625
    Member
    Posted 1 year ago #

    Thanks for the post, because you helped me solve this issue. In the admin bar is a little notification thing that looks like a comment bubble. Go to wp-admin. Click on Jetpack. There is a box that says notifications with a learn more button. When you click learn more, the deactivate button shows up. Click deactivate. This gets rid of the message.

  12. ronkusadeniran
    Member
    Posted 1 year ago #

    Thank you tiger625... worked for me....

  13. tiger625
    Member
    Posted 1 year ago #

    Glad that worked, it was really annoying me

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic