WordPress.org

Ready to get started?Download WordPress

Forums

Bushwick
[resolved] Only one blog post showing when setting is put to 5 (9 posts)

  1. amzy01
    Member
    Posted 5 months ago #

    I'm starting a new blog and am using the Bushwich theme. I have my "reading" setting set to show 5 posts with full text. Only one full post shows up and the rest are links with read me buttons. I'd like for all my 5 posts to show up with full text on my page instead of just links. I am not technical at all. I don't know if this is something within WordPress that I need to change or within the Bushwick theme. Can someone please help? Thanks.

  2. Hi there, in the Bushwick theme, only the first post shows up in full, no matter how many posts you set in your Reading Preferences, as you can see in the demos here:

    http://bushwickdemo.wordpress.com/

    http://wp-themes.com/bushwick/

    If you need more than one post to display in full and you're not comfortable editing theme files, you're probably better off with a different theme.

    Let me know if you have any other Bushwick questions.

  3. amzy01
    Member
    Posted 5 months ago #

    I'm not comfortable editing, but my husband probably can if he has some kind of direction to do so. I'd appreciate it if you can pass on the editing information. I've spent so much time getting my blog ready including custom graphics that a different theme (specifically finding another theme that has a large side photo header) isn't really an option at this point. Thank you!

  4. Sure! The first thing you'll need to do is set up a child theme.

    Making a child theme means your changes won't be overwritten when you update the theme. If you/your husband are new to child themes, you can explore these guides:

    http://codex.wordpress.org/Child_Themes
    http://op111.net/53/
    http://vimeo.com/49770088

    Once your child theme is set up, make a copy of the index.php file from the parent theme and place it in the child theme folder.

    Next, you'll need to make a couple of edits to the copy of the file in your child theme folder.

    Change line 29 from this:

    get_template_part( 'content' );

    to this:

    //get_template_part( 'content' );

    The two slashes in front of the line mean that you're commenting out that part of the code, rendering it inactive.

    Next, change line 34 from this:

    get_template_part( 'content', 'preview' );

    to this:

    get_template_part( 'content' );

    Those two changes should do the trick, and display full posts on your blog page, instead of just the post titles.

    Let me know how it goes!

  5. amzy01
    Member
    Posted 5 months ago #

    Thank you so much! I just printed this out and will be giving it to my husband! I will let you know.

  6. amzy01
    Member
    Posted 5 months ago #

    It worked! Now, I have one other question. I don't get a comment box under the posts. The like and share buttons are there. I have to click on the title link to go to another page to see the comments. Is there anything in the code that needs to be changed to make it work? Thank you!

  7. It worked!

    Great!

    I don't get a comment box under the posts. The like and share buttons are there. I have to click on the title link to go to another page to see the comments.

    That's how nearly all WordPress themes work - the comment box and comments are displayed on the single post view, not on the blog index.

    If you have any new questions, please start a new thread, thanks!

  8. T.Ouwerkerk
    Member
    Posted 4 days ago #

    Thank you so much Kathryn, i had the exact same question ;).

    It worked perfectly on my main page but the changes didnt apply on the category menu. check: http://www.wherearewe.nl/afrika -> see menu -> if you press on "Australiƫ" you only see the titel of the post, no preview.

    i guess its just as easy to change that aswell or am i wrong?

    Thanks in advance.

  9. T.Ouwerkerk
    Member
    Posted 1 day ago #

    After i did the 2 steps you named i got 1 new problem. On my main page it didnt show the last post anymore.

    I fixed that by changing: (sorry dont have line numbers)
    else :
    get_template_part( 'content', 'none' );

    To:
    else :
    get_template_part( 'content' );

    Stil i would love to fix my other question:
    In my category overview i only see the post titels and not the previews. (also see my post above this one)

    Thanks in advance

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.