WordPress.org

Ready to get started?Download WordPress

Forums

WP User Avatar
[resolved] Only logged in users see avatar (8 posts)

  1. Martyr13
    Member
    Posted 1 year ago #

    I thought I had this plugin working well, but the problem is that if a visitor comes to my site (intellectualsavage.info), and they read an article, they don't see the new avatar photo that I uploaded. They see a resized facebook photo of me which is all blurry. When I'm logged in and I go to read an article, I get the picture that I uploaded. What could be causing different users to see different avatars? I'm using the Arras theme.

    http://wordpress.org/extend/plugins/wp-user-avatar/

  2. Bangbay Siboliban
    Member
    Posted 1 year ago #

    Hi Marty,

    You're using a plugin called Social Login for WordPress which seems to be causing a conflict. There is a setting that says "If the user's social network profile has an avatar, should we show it as the default avatar for the user?" Is that setting set to "No, display the default avatars (Default)"?

  3. Martyr13
    Member
    Posted 1 year ago #

    I too thought the problem was Social Login, so I tried the change you suggested, and it didn't do anything, and I've completely deactivated and deleted it, but I just can't get rid of that blurry image. I deleted my oneall website and my Facebook ap that are linked to the social login plugin as well. I've even clicked on the option to not show avatars and it's STILL there, but only for visitors. When I'm logged in, I see what I expect to see.

  4. Bangbay Siboliban
    Member
    Posted 1 year ago #

    It's possible you're viewing a cached version of your page. You're using WP-Super-Cache. Could you try rebuilding the cache or deactivating the plugin?

  5. Martyr13
    Member
    Posted 1 year ago #

    No, I deactivated the plugin, and I still see the old blurry image when I'm not logged into the website. Do you see the image of me in a grey t-shirt holding onto little chickens? http://intellectualsavage.info/before-paleo/

  6. Bangbay Siboliban
    Member
    Posted 1 year ago #

    I see the blurry image, too. When I look at the source code of your page, at the bottom is:

    <!-- Dynamic page generated in 0.311 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2013-01-22 21:05:35 -->

    So I'm actually viewing a cached page that was generated 5 days ago. It's possible there are some settings left from the plugin. Here's how to uninstall the plugin: http://wordpress.org/extend/plugins/wp-super-cache/other_notes/

  7. Martyr13
    Member
    Posted 1 year ago #

    Thanks, at the very least, I got rid of that image that has been plaguing me since last night. I reactivated the plugin, and turned caching off. I still have some configuring to do to get things how I want them, but the image as gone, and hopefully, I'll be able to get your plugin to work now. You've been very helpful.

  8. Bangbay Siboliban
    Member
    Posted 1 year ago #

    No problem. Thanks for trying out my plugin!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.