WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Only latest post appears in blog (10 posts)

  1. makta112
    Member
    Posted 1 year ago #

    Hello

    Only the very latest blog post is shown on my home-page...

    What might the problem be? In the settings I've written 10 by "Blog pages show at most". I don't know if it has anything to do with it, though.

    My home-page: http://www.geimaku.com/

    Thanks.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the parent Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. makta112
    Member
    Posted 1 year ago #

    Hi,

    I switched over to the parent theme and it worked fine with it but the child theme is still showing the latest entry only.

    The last thing you've mentioned: resetting the plugins folder by FTP -- if I do that will all be edits then be gone??

    EDIT: Oh, and I turned off all the plugins. That didn't help either :(
    (They're still off.)

  4. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    what is the code in index.php and content.php of your child theme?

    please use the pastebin - how-to

  5. makta112
    Member
    Posted 1 year ago #

    Ok, wait a sec.

    --

    Here's the index.php

    http://pastebin.com/bAtBrG62

    I don't have content.php in child theme? Here's what I have.

  6. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    this is a very specialized index.php - to call a number of categories with one posts each.

    the category ids are inserted in line 13:

    $my_cat_array = array(5,3,22,1);

    - do you have these categories in your site?
    - do you want to show one post of each of these categories on your front page?

    (I guess that only the one post with 'uncategorized' = id 1 is showing at the moment)

    if not, don't just copy any odd index.php for but find a more general index.php

  7. makta112
    Member
    Posted 1 year ago #

    Hi,

    I don't think I have those categories on my site. I only have the uncategorized one at the moment.

    Also, where can I find a "more general" index.php? :)

    Thanks.

  8. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    where can I find a "more general" index.php? :)

    possibility a:
    don't add any index.php into your child theme, i.e. remove the one that is currently there - then the index.php from the parent theme will get used.

    possiblity b:
    copy index.php from the parent theme into the child theme; then make any edits you need.

  9. makta112
    Member
    Posted 1 year ago #

    Ok, thanks.

    It should be fixed when I remove all the codes, yes?

    --

    It fixed it! Thank you!

  10. joeleen
    Member
    Posted 1 year ago #

    I'm having this same problem, all of the sudden ONLY last post shows on my blog and the wordpress 'bar" at the top is also missing, along with the right hand column that's normally there with a search box & the company's address.
    http://rebuildit.org/GRC/blog/
    viewing just a single category works fine:
    http://rebuildit.org/GRC/category/events/

    This happened after deactivating socialble and installing shareaholic. Now I've deactivated both and uninstalled both. I've also tried deactivating ALL other plugins but nothing helps.

    I've tried reverting back to 2011 and in that theme, NO blog posts show on the main blog page and a subcategory of posts appears perfectly just like in my custom theme.

    Ideas? thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic