WordPress.org

Ready to get started?Download WordPress

Forums

only home page visible on server (5 posts)

  1. motix
    Member
    Posted 2 years ago #

    Hi, I just transfered wordpress from localhost:8888 to the server, i changed "all" necessary fields in database(wp-options - site url, home) also changed wp-config details for my server.
    Now only i can see my home page, the other pages are 'page templates' which cannot be displayed, wordpress cannot see it, probably there is something worng with directory, anyone can give me an advice what should i do to make it work? I checked different forum posts but could not find anything to solve it.

    this is a link to the web i am working on:


    link to the web

    thanks for a help:)

  2. esmi
    Forum Moderator
    Posted 2 years ago #

  3. motix
    Member
    Posted 2 years ago #

    i did review it, but did not find what is the problem :-/

  4. Nikki Blight
    Member
    Posted 2 years ago #

    Try resetting your permalinks to the default settings. If it starts working after you do that, then mod_rewrite is not enabled on your server and you'll need to contact your host.

  5. motix
    Member
    Posted 2 years ago #

    Thank you so much!!, changing permalink to its default settings, fix my problem i mean, I just contacted my server provider and asked for mod_rewrite, he told me to create a .htaccess file with some functions in it, I did it as he told me, then I changed permalink to my settings like /%postname%/ and from this time everything so far so good.

    The last thing before finishing a web for a client is to set newsletter, i dont know how newsletter form should looks like(i use Email newsletter for wordpress) I read some newsletter for wordpress documentations and checked some other websites, but i couldnt find a solution, still doesnt add subscribed people to the admin interface. Any one with sugestions how to do it?

    thank you again kionae!!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.