WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
[resolved] Only displays small window on some computers (5 posts)

  1. me480811
    Member
    Posted 1 year ago #

    The google doc embedder has worked fine for me so far.
    EXCEPT that on some computers only a small portion of my uploaded PDF can be viewed. It looks like a long horizontal and narrow rectangle (I have a screenshot of it, but don't know where to upload it)
    The scrolling still works fine, and the pdf can be fully seen once I click on the full screen mode. But like I said, only part of my pdf can be seen through that rectangle, even with the scrolling. I tried changing the height in enhanced viewer and with a shortcode, which didn't do anything.

    Any suggestions on how to fix this problem?

    PS is there also any way to get rid of the download button once the pdf goes to full view?

    Thanks!
    Michelle

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Michelle,

    Could you post that screenshot somewhere to your web site and put the link here? Or else attach it to an email to me (my email address is in the GPL statement at the top of gviewer.php). When you say "some computers" do you mean specific browsers, or it's totally random?

    GDE 2.5 (currently in beta) will allow you to remove the download link in full screen view, as well as block the download completely even if the user gets the link manually from the source code of the page.

    Thanks,

    Kevin

  3. me480811
    Member
    Posted 1 year ago #

    Hi Kevin,
    Thanks for the response. I will email you the attachment.

    And it doesn't seem to be a browser problem for me, it is just completely random depending on which computer I am using. Weird.

    And great, since I am displaying my resume and don't necessarily want people to download it.

    Thanks!
    Michelle

  4. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Michelle,

    Your height is set to 100%. That doesn't work quite the way it seems. Setting a height of 100% means that the iframe will be 100% the height of its parent container (the div it resides in), not 100% of the page. Since the parent div doesn't have an explicit height, you're getting the minimum the iframe contents will allow.

    I recommend you set a pixel height (you may have to experiment to get the size you want).

    Hope this helps,

    Kevin

  5. me480811
    Member
    Posted 1 year ago #

    Ok thanks!
    I'll play around with it and see if it changes anything.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.