WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] only default permalinks working (4 posts)

  1. mikecicc
    Member
    Posted 6 years ago #

    I am in the process of changing web hosts, and I've started a test blog on my new host to ensure everything is working properly.

    test URL: http://www.mikecicc.com

    when default permalinks are enabled, the pages all work fine, but when i change the permalink structure to anything else, i get 404 errors.

    I imagine this had something to do with mod_rewrite

    so i added an .htaccess file in my blog's root directory with the following:

    RewriteEngine ON

    i waited over 24 HOurs...and I'm still getting the 404 errors on page requests...

    anyideas where i can start trying to resolve this? or what the problem is related too? or is my .htaccess syntax even correct?

    THanks in advance!!

  2. moshu
    Member
    Posted 6 years ago #

    1. Ask your host whether the settings for "nice" permalinks are enabled (mode_rewrite, AllowOverride)
    2. No, that's NOT the proper htaccess content. Wp either writes it for you or it gives you the code at the bottom of your Permalinks page.
    3. The reading: Using_Permalinks

  3. mikecicc
    Member
    Posted 6 years ago #

    thanks ! I will chmod on my .htacess file and let WP write it for me..

    if that fails ill contact my host and see if those php settings are enabled...

    cheers

  4. mikecicc
    Member
    Posted 6 years ago #

    that worked, just needed to chmod 777 on my .htaccess, allow WP to write it properly, then changed permissions back, "pretty" permalinks now work fine..

    thanks again

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags