WordPress.org

Ready to get started?Download WordPress

Forums

Superhero
[resolved] Featured content slider not displaying (11 posts)

  1. Jen
    Member
    Posted 6 months ago #

    Hello Superhero themers! I love the Superhero theme and have been trying to implement it on my new WordPress site. I followed the instructions posted elsewhere in this support to add Jetpack, and then added the tag "featured" to Settings > Featured Content. I've added the "featured" tag to several posts, and on those posts, also set the banners I created (each are png files and greater than 1200px wide) as the "Featured Image" for those posts. For whatever reason, the featured content slider will not display on my home page, though the "featured image" is displaying full-width in the posts themselves. Can anyone help with this? It looks like I'm not the only one having issues with the slider, but so far I've followed all of the instructions I could find.

    When I edited the original theme example posts, two of my tests displayed temporarily. But I deleted the sample posts and have not been able to "bring the slider back" since. I can't find any other options for managing the display of the theme's Featured Content via the home page slider, or any way to specify that the slider should be there. Does it matter whether your home page is set to a static page or list of posts? (Well, I've tried it both ways with no success, so i'm guessing that isn't it.) I am new to WordPress but comfortable with code edits and FTP, if that helps my case!

    Here's my web site:
    http://finelinefilms.org

    I chose this theme primarily for the slider, and am really hoping someone can help!
    Thank you,
    Jen

  2. Hi Jen, could you please try using a plugin to regenerate your thumbnails, like this one:

    http://wordpress.org/plugins/regenerate-thumbnails/

    The theme uses a specific thumbnail size that needs to be created before the images will appear.

    Let me know if it does the trick!

  3. Jen
    Member
    Posted 6 months ago #

    Hi Kathryn,
    Thanks for your response! I installed and tried two different plugins, the one you listed above ("Regenerate Thumbnails") and another ("Force Regenerate Thumbnails"), and both appeared to have successfully regenerated the thumbnails for each of my three featured posts, but neither worked in terms of getting the home page slider to re-appear. I double-checked everything, including the image sizes (each featured image is 1200px wide, one is 1280). They are all tagged "featured" which is the featured content tag in my reading options. Jetpack is installed and working fine, and I also updated all of my plugins, just in case. (Also used FTP to make sure the theme files hadn't been modified, and cleared browser caches and tried multiple browsers in case it was CSS related.) I tried de-activating and re-activating the Superhero theme, too. Shoot! Do you have any other ideas about what it might be, or what I should try?
    Thanks,
    Jen

  4. Hi Jen, thanks for trying that. Could you please try selecting a different tag for your featured posts (i.e. something other than "featured") and let me know if that works?

  5. Would you also mind providing links to the specific posts you've marked with your featured-content tag so I can take a look? Thanks!

  6. Jen
    Member
    Posted 6 months ago #

    Hi Kathryn,
    Changing the tag word totally worked - go figure! Thanks for your help.
    Jen

  7. Hey Jen - glad that did the trick.

  8. canamorthodox
    Member
    Posted 1 month ago #

    Hi all,

    I'm having the exact same problem as everyone above. I tried changing the tag, it didn't work.

    I don't know how to use the plugins because I'm doing all my work online, not locally. I tried to install wordpress locally, but I couldn't figure out how to link it to my actual blog, instead it was starting a new blog! So I'm so confused now as to how to deal with any of this.

    My site is: http://canamorthodox.wordpress.com

    Any help is appreciated. Thank you!

  9. canamorthodox
    Member
    Posted 1 month ago #

    PS --> I just changed the theme to ascetic because my newest blogpost wouldn't show at all on the front page anywhere!

  10. designsimply
    Member
    Posted 1 month ago #

    canamorthodox, if you were still using the Superhero theme at http://canamorthodox.wordpress.com/ then I would have recommended double checking the tag setting by changing it to something else and then changing it back and re-saving, and I also would have had you check to make sure your featured images were at least 960px (which is a requirement of the Superhero theme).

    Ascetica is great too! So stick with that if you're happy with it. Also, since your blog is hosted at WordPress.com, you can use the support forums at http://en.forums.wordpress.com/forum/themes where you can get help on WordPress.com things directly. This forum is more general and often there is advice here that applies to non-WordPress.com setups that you may not be able to do (like creating a child theme). It's best to post in the forum which matches your setup. :)

  11. canamorthodox
    Member
    Posted 1 month ago #

    Thank you so much!

Reply

You must log in to post.

About this Theme

About this Topic