WordPress.org

Ready to get started?Download WordPress

Forums

Ongoing Image/Media Uploader problems (3 posts)

  1. Tom
    Member
    Posted 5 years ago #

    Hi,

    I have been through every step in the sticky post above and still I cannot upload an image to my blog. I get an "http error" message with the flash uploader and an "Error 500 - Internal server error" with the 'browser uploader'.

    Some more information:

    1. The image I am trying to upload is a color .jpg file, 1024 x 768 and 73KB in size

    2. The file permissions of my upload directory are set to 777

    3. I am using Firefox 3.0.1 with the latest Flash plugin

    4. I have added the mod_security code to an .htaccess file in the root directory and wp_admin directory

    This problem is also occurring in IE7.

    Are there any definitive fixes for this issue yet as I have been searching for hours now.

    Thanks

  2. Tom
    Member
    Posted 5 years ago #

    Is it just accepted that with the new WordPress we can't upload images to our blogs?

  3. kcitesting
    Member
    Posted 5 years ago #

    No way!. Just be persistent. I spent hours on this as well with both wp 2.5 and 2.6 installs. I too added the mod_security code to the .htaccess file in both directories, did the CHMOD thing, did the image settings location thing, did everything and like you - no change!!.

    Then I took closer look and found the byte size on .htaccess was lower than it should have been if it had changed (I did the mod_security stuff on the remote server using cpanel). Also, I found that the leading '.' was missing after saving the file in cpanel. Don't ask me how or why, but for some reason the file didn't save properly. I did 'view file' in my ftp client on the remote htaccess and sure enough, my edits were not there and the leading '.' missing.

    I started all over using my ftp client, added the following to the .htaccess file and uploaded it to WP site root and it all worked, on both wp installs (the second was just a test install)!!:

    # BEGIN WordPress

    # END WordPress

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    I'm not entirely sure what was causing this but the symptoms are similar to what many others have experienced.

    Hope this helps someone

Topic Closed

This topic has been closed to new replies.

About this Topic