WordPress.org

Ready to get started?Download WordPress

Forums

Easy Modal
[resolved] One of the modals not loading? (8 posts)

  1. carolinadreaming
    Member
    Posted 10 months ago #

    Hi,
    I'm having a problem with one of my modal windows not loading...

    If you look at http://www.carolinadreaming.com/clients/mikala, click the first image and add it to the cart, then click "checkout" and it's supposed to open the checkout page in a modal window (it only contains the checkout page shortcode for the Easy Digital Downloads plugin.)

    But the other 3 (investment/ exposure/ contact) links located in the footer seem to still be working perfectly fine. I'm not sure what I did wrong... any ideas on what I can try to get it working?

    Thanks in advance!!

    http://wordpress.org/plugins/easy-modal/

  2. danieliser
    Member
    Plugin Author

    Posted 10 months ago #

    After taking a look it appear that you are using v1.0.4 or earlier? Have you considered upgrading to the latest version? v1.2 introduced a new way of loading the modal windows to help deal with bugs like your experiencing.

    What is acutally happening currently is that it loads the code for the modal but the modal contains javascript that apparently isnt loaded properly.

    I will have to test with Easy Digital Download but i believe that it should work pretty close to out of the box with the newest versions.

    If you can afford to wait a day or so i will test it out and get back to you if not you are free to try it yourself. Or setup a test site to put both plugins on and try it that way.

  3. carolinadreaming
    Member
    Posted 10 months ago #

    Sorry for the delay in responding.
    It's saying I have version 1.7.2 in the System Info tab, but I'll double check for new updates a little later today. I would really appreciate it if you could test it whenever you get the chance, since I don't know how and wouldn't know what to look for or how to fix it.

    Thanks so much!

  4. danieliser
    Member
    Plugin Author

    Posted 10 months ago #

    Sorry for the vague advice. I meant it appeared you were using Easy Modal v1.0.4 or earlier. Check to see if you have an update available for easy modal and get it updated to the latest version. And let me know.

  5. carolinadreaming
    Member
    Posted 10 months ago #

    Ok, I got it updated to 1.2.2. Hooray I think it's working!!! Thanks so much for your help so far! Except now there's a new problem- it isn't scrolling the content when it's too long for the box, it's just spilling down the page. (e.g. the "exposure" link in the footer). What do you think?

  6. danieliser
    Member
    Plugin Author

    Posted 10 months ago #

    This is by design mainly because of responsive needs to make them compatible with mobile screens. If you want it the other way it will work fine on desktops but will probably be larger than screen for mobile.

    The way of is now you scroll down the page to scroll the modal. If you set size to custom and define height and width you can use css to make it scroll like it did.

  7. danieliser
    Member
    Plugin Author

    Posted 10 months ago #

    If you dont have any further issues please take a moment to rate and review the plugin http://wordpress.org/support/view/plugin-reviews/easy-modal

  8. carolinadreaming
    Member
    Posted 10 months ago #

    Ok that makes sense. Thanks again for all your help!!

Reply

You must log in to post.

About this Plugin

About this Topic