WordPress.org

Ready to get started?Download WordPress

Forums

One click upgrade problems in 1.4.6.3 (5 posts)

  1. jikvig
    Member
    Posted 6 years ago #

    I try to one click upgrade my page, but all I get in response is;

    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /home/virtual/jikvig.com/public_html/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 721

    Warning: file_get_contents(http://wordpress.org/extend/plugins/all-in-one-seo-pack/all-in-one-seo-pack.zip) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /home/virtual/jikvig.com/public_html/wp-content/plugins/all-in-one-seo-pack/all_in_one_seo_pack.php on line 721

    Upgrade failed: Could not download distribution (http://wordpress.org/extend/plugins/all-in-one-seo-pack/all-in-one-seo-pack.zip)

    What have I done wrong?

  2. uberdose
    Member
    Posted 6 years ago #

    Your provider has disabled file_get_contents() for URLs, that's the problem :( I'd ask support why they're doing this and which options you have.

  3. v1ktor
    Member
    Posted 6 years ago #

    uberdose,
    would it be possible to have an alternative upgrade file that utilizes cURL instead of file_get_contents()? A lot of hosts disable external file access due to security reasons?
    (ex: Dreamhost) This would solve the problem for everyone.

    v1ktor

  4. uberdose
    Member
    Posted 6 years ago #

    What would be the benefit? If your hoster doesn't allow file_get_contents() it probably doesn't allow any other access to the outside world, no?

  5. Joni
    Member
    Posted 6 years ago #

    did you disable your plugins before upgrading?

Topic Closed

This topic has been closed to new replies.

About this Topic