WordPress.org

Ready to get started?Download WordPress

Forums

WPtouch Mobile Plugin
[resolved] On my iPhone can't back to WP Touch mode (12 posts)

  1. thecompasswithin
    Member
    Posted 1 year ago #

    Hi, the WP touch was working fine and I pressed the option to go back to the regular view (saying that there will be a button at the bottom to go back to the view).
    Once I switched, I don't see the button anymore so I can't go back to WP touch view.
    Is it the way my blog/website is designed?
    Thanks for the help!
    here's the blog link:
    http://thecompasswithin.com/blog/

    http://wordpress.org/extend/plugins/wptouch/

  2. mm886
    Member
    Posted 1 year ago #

    I'm using an HTC Android phone and just had the same problem. I'm using the latest free version which seemed to work fine until I tried/tested the button on the mobile site that was supposed to toggle between mobile & regular view. It switched back right enough, but then there was no further button in the footer to switch back to the mobile version and all subsequent attempts to pull up the mobile version on either the original phone or a tablet just show the full site. I have tried engaging/re-engaging the plugin and clearing the cache on the phone, but the mobile version seems to have vanished.

    Help please, thanks.

  3. einreb77
    Member
    Posted 1 year ago #

    hi guys, This was annoying me until i dug in and found a solution. it's a css issue. the toggle switch is a few layers too deep, so when you tap on it, you're actually tapping on a transparent layer that's over it (from your template). i found a way to bring the toggle switch to the front. you need to add z-index to the css. go to /wp-content/plugins/wptouch/themes/core/core-css and open the "wptouch-switch-link.css" file. i added "z-index: 99;" to all the switch styles. there's also another css file that has the same styles (not sure if it affects the toggle switch). i added z-index as well, just in case. go to "/wp-content/plugins/wptouch/themes/default" and edit style.css. on line 2100 (ish), you'll see the same style definitions as in the previous file. just add "z-index: 99;" to them. this worked for me. good luck!

  4. thecompasswithin
    Member
    Posted 1 year ago #

    Thanks so much! I'll do this later today.
    You just might have helped me solve another similar issue with WP Socializer, I couldn't see the float bar on the side of my website, probably a very similar problem!

  5. thecompasswithin
    Member
    Posted 1 year ago #

    Hmm, it didn't work, I even made my backgrounds of the page negative z-index values.. I'd appreciate any other suggestions.
    Thanks!

  6. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    When you are unable to see your mobile theme with WPtouch active, it's most often due to a caching plugin or service overriding your posts and pages with stored files that use the destkop theme.

    You may configure your caching plugin not to cache mobile pages nor to serve cached pages when mobile devices are detected. To do so, enter the user agents found under Advanced Options > Custom User-Agents to the "rejected user agents" areas in your caching plugin's settings. Remember to clear your plugin, browser, and device caches before retesting.

  7. thecompasswithin
    Member
    Posted 1 year ago #

    HI, thanks for the feedback, there is already a list of devices in there and one of them is the iPhone which is what I'm using. Do I need to add something else?

  8. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    thecompasswithin,

    Please make sure that wp_footer() is included in the footer.php file of your desktop theme to ensure that WPtouch can properly show the switch link in the footer of your desktop theme.

  9. thecompasswithin
    Member
    Posted 1 year ago #

    Thanks!
    I'm a bit unfamiliar with coding, it's been a while.
    Do I just put "wp_footer()" anywhere in the footer.php?
    Should it be at a specific place?
    And should it have ";" at the end? Or some other variable passed onto it?

  10. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    You'll want to place the call for the footer of your theme <?php wp_footer(); ?> just before the closing body tag </body>. If in doubt, see the WordPress codex for the correct syntax: http://codex.wordpress.org/Function_Reference/wp_footer

  11. thecompasswithin
    Member
    Posted 1 year ago #

    It worked!
    Thank you! :)

  12. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 1 year ago #

    You're very welcome!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic