WordPress.org

Ready to get started?Download WordPress

Forums

sweet Captcha
[resolved] "Omit captcha for registered users" has a minor bug (5 posts)

  1. Muhammad Muhaimin
    Member
    Posted 10 months ago #

    I have enabled the "Omit captcha for registered users" option in admin page.
    When I open a blog post, SweetCaptcha still visible below the comment form.

    I searched inside the codes, and I found that this is just a minor bug in /library/public.php line 65 and 83:
    'sweetcaptcha_form_ommit_users' (with double m)
    should be:
    'sweetcaptcha_form_omit_users'

    Now the captcha is disabled for logged in users.
    Problem solved.

    http://wordpress.org/extend/plugins/sweetcaptcha-revolutionary-free-captcha-service/

  2. xValkyrie
    Member
    Posted 9 months ago #

    This fixed the comment form, but the contact form still shows a captcha. After looking through the code it appears the contact form doesn't even have this option coded in.

  3. Muhammad Muhaimin
    Member
    Posted 9 months ago #

    yes, I think so.

  4. Sweet Captcha
    Member
    Plugin Author

    Posted 5 months ago #

    Hi Muhammad, there were several updates to Sweet Captcha since your ticket was opened.
    The service is now highly stable, please let us know if your issue persists at support@sweetcaptcha.com.

  5. Muhammad Muhaimin
    Member
    Posted 5 months ago #

    Not yet.
    Every time I update Sweet Captcha, I still have to change:
    ommit
    to:
    omit

Reply

You must log in to post.

About this Plugin

About this Topic