WordPress.org

Ready to get started?Download WordPress

Forums

OMG newbie unable to increase file size upload limit (15 posts)

  1. grampazero
    Member
    Posted 1 year ago #

    Yea, total WP newbie, but I've tried everything I could find here(maybe incorrectly?) for increasing my upload size from 8MB to 20MB.

    2 methods i've seen here are 1)change the php.ini file...ok, so I put this in:

    Maximum allowed size for uploaded files.
    upload_max_filesize = 19M
    post_max_size = 20M
    (also tried 20 and 20)

    and it doesn't work.

    and 2) change the htaccess file,

    so I tried this:

    #Change upload limits
    php_value memory_limit 64M
    php_value post_max_size 20M
    php_value upload_max_filesize 19M
    php_value max_execution_time 600
    #Change upload limits end

    and I get an internal server error and can't even log in to WP.

    This sucks cause it's a non- commercial site and I'm guessing I gotta go to Amazon S3 just to upload a lousy 20MB video file?

    Any help on this well-worn topic is appreciated! thanks.

  2. David Choi
    Member
    Posted 1 year ago #

    You might have to contact your host support, to see if they have set some kind of limitation for this.

  3. grampazero
    Member
    Posted 1 year ago #

    Oops,

    Perhaps I also should say that I have used the host(Doteasy.com) admin panel upload, and it DID upload a file larger than 8MB(they say their limit is 20). I can see it in the directory under:
    public_html/wp-content/uploads/2012/08

    but when I log into WP, it will not show up in the media section.
    Is that because the WP 8MB limit is blocking it, or am I missing something? thank you.

  4. David Choi
    Member
    Posted 1 year ago #

    Create a phpinfo.php file and upload to your site, to verify the PHP file upload limit by visiting

    http://yoursite.com/phpinfo.php

    to see if the size limit setting is indeed in effect.

  5. Doodlebee
    Member
    Posted 1 year ago #

    Have you added:

    define('WP_MEMORY_LIMIT', '16M'); to your wp-config.php file?

  6. grampazero
    Member
    Posted 1 year ago #

    could you please tell me where the wp-config.php file is located...i can't seem to find it.thank you.

  7. Doodlebee
    Member
    Posted 1 year ago #

    It's at the root of your WordPress installation. it's how WordPress connects to your database. (you have to FTP into your server to get it.)

  8. David Choi
    Member
    Posted 1 year ago #

    It's at the root of your WordPress site. You need to use FTP client like

    http://filezilla-project.org/download.php?type=client

    or use File Manager provided by your hosting company's panel.

  9. David Choi
    Member
    Posted 1 year ago #

    BTW, here is a snapshot, where you can locate wp-config.php among others:

    http://webdesignworkplace.com/tag/secure-wp-configphp/

  10. grampazero
    Member
    Posted 1 year ago #

    TY all so much...i tried Shelly's code (using 20MB) in the config file but the 8MB in the WP media uploader will not change yet. Gotta run to the bank, but later will retry your suggestion in case i have made incorrect entries. ARG-h-h-h-h-h-h!!!!!

  11. Doodlebee
    Member
    Posted 1 year ago #

    Yeah, that sounds to me like a hosting issue then. Some hosts allow you to edit the php.ini file, but some don't. You may have to contact them.

  12. grampazero
    Member
    Posted 1 year ago #

    hi again. My host support directed me to this link in order to verify that my upload limit is 20 MB:

    singathome.org/phpinfo.php

    When I go there, I do see this line:
    upload_max_filesize 20M 20M

    but then I see THIS line:

    post_max_size 8M 8M

    Am I wrong, or doesn't this line have to be changed to 20M? I am hoping the stupidity rests with me and not my host.
    thanks for all of your help.

  13. David Choi
    Member
    Posted 1 year ago #

    Yes, change that to 20MB.

  14. grampazero
    Member
    Posted 1 year ago #

    Thank you very much David and Shelly for your generous attention to my problem. I guess you'd say my problem is now "solved"..lol. They just told me they can't change the setting. Refund time! But I really appreciate your help!

  15. David Choi
    Member
    Posted 1 year ago #

    Glad you've found the source of the problem. Just have to get a good host now :)

Topic Closed

This topic has been closed to new replies.

About this Topic