WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Old favicon showing on registration page (20 posts)

  1. Owen
    Member
    Posted 9 months ago #

    I had an old favicon and replaced it. Easy. Although on my registration page it still shows it. I tried deleting it from my cPanel file mannager but it's still showing! My website is http://www.owensinclairjones.co.uk

  2. Timothy Jacobs
    Member
    Posted 9 months ago #

    I don't see any favicon. It is likely that it was just cached, that was why it wasn't changing. Try emptying your browsers cache.

  3. Owen
    Member
    Posted 9 months ago #

    I see my favicon though. It says I have a favicon on my Simple Catch theme options

  4. Timothy Jacobs
    Member
    Posted 9 months ago #

    not any more since you deleted it. try emptying your cache. Take a look http://i42.tinypic.com/r9pt0i.png

  5. Owen
    Member
    Posted 9 months ago #

    would it work if I just re-uploaded the favicon?

  6. Timothy Jacobs
    Member
    Posted 9 months ago #

    yes and clear your cache.

  7. Owen
    Member
    Posted 9 months ago #

    is it showing now?

  8. Owen
    Member
    Posted 9 months ago #

    as it doesn't show on register page

  9. Timothy Jacobs
    Member
    Posted 9 months ago #

    Are you putting the favicon in your wp installation directory, or are you using a plugin?

  10. Timothy Jacobs
    Member
    Posted 9 months ago #

  11. Owen
    Member
    Posted 9 months ago #

    I'm uploading it in my theme options

  12. Timothy Jacobs
    Member
    Posted 9 months ago #

    Take a look at that link. Your theme isn't extending the favicon to the admin area.

  13. Owen
    Member
    Posted 9 months ago #

    but where do I put the snippet though? It said put it in your funcionality plugin but I'm not using a plugin!

  14. Timothy Jacobs
    Member
    Posted 9 months ago #

    You can put it in your themes functions.php file

  15. Owen
    Member
    Posted 9 months ago #

    // Add Favicon //

    function diww_favicon() {
    echo '<link rel="shortcut icon" type="image/x-icon" href="'.get_bloginfo('stylesheet_directory').'http://diww.s3.amazonaws.com/favicon.ico.gzip" />';
    }
    add_action('wp_head', 'diww_favicon');
    add_action('admin_head', 'diww_favicon');

    Is that what I put in my theme funcions?

  16. Owen
    Member
    Posted 9 months ago #

    All in one favicon works for site and admin but not login/register page

  17. Owen
    Member
    Posted 9 months ago #

    still not showing!

  18. Owen
    Member
    Posted 9 months ago #

    The hideous old favicon is showing on the register page! I cleared my cache again which made it show on the admin, which was good, but it still won't show on my register/login page!

  19. Owen
    Member
    Posted 9 months ago #

    now I know why. I checked it on chrome and it worked, however on IE it didn't, probably because it's an older browser so how do I make it show on older browsers?

  20. Owen
    Member
    Posted 9 months ago #

    Found a suloution!#

    function favicon4admin() {
     echo '<link rel="Icon" type="image/x-icon" href="http://www.owensinclairjones.co.uk/wp-content/uploads/2013/07/favicon5.ico" />
     <link rel="Shortcut Icon" type="image/x-icon" href="http://www.owensinclairjones.co.uk/wp-content/uploads/2013/07/favicon5.ico" />';
     }
     add_action( 'login_head', 'favicon4admin' );
     add_action( 'admin_head', 'favicon4admin' );

Reply

You must log in to post.

About this Topic