WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Okay to change address URL? (5 posts)

  1. billtooabsent
    Member
    Posted 8 years ago #

    I just transferred a domain that had been running MT. During the transitional phase, my Host (BlueHost) had set me up with
    http://70.103.189.76/~tooabsen/theherald/

    And so I went ahead and started setting up my WP Install.

    Now the Domain transfer is complete, and my WP blog is found at

    http://www.tooabsent.com/theherald

    But when navigating, or for permalinks, etc. WP takes a visitor to http://www.addresses like
    http://70.103.189.76/~tooabsen/theherald/?cat=4

    Is this in any way insecure? I would like to have all pages be tooabsent.com/theherald/example/example...

    I did change the URL and was locked out, had to go into myPHPAdm to fix it.

    I have found the steps to put my blog in its own director, and I understand that this is how to SAFELY change the URL.

    Is this what I need to do in order to have the address bar NOT SHOW my Server IP?

    Sorry for the long-winded question, but I am just getting the hang of the lingo. WP has already outshone MT, for me. But I want to keep learning as much as possible.

    Bill

  2. ulyssesr
    Member
    Posted 8 years ago #

    Bill,

    I think you need to change your WordPress Address (URI) and Blog Address (URI) which is both located in the WordPress Admin pages. Choose Options - General tab. Type in your changes and Update Options.

    Hope that helps.

    Regards,
    Ulysses

  3. billtooabsent
    Member
    Posted 8 years ago #

    Well, I broke it again.

    I tried to change the Values in General Options, and got a 404.

    So I followed the steps to shange things back in phpMyAdmin to the http://70.103.189.76/~tooabsen/theherald

    Went back to General options and changed back... but still get 404.

    And cannot log-in in a new browser window.

    Site loads but with no structure or theme.

    Trying to get back to Site results in this in Address bar, producing a 404:

    http://70.103.189.76/~tooabsen/theherald/wp-admin/www.tooabsent.com/theherald/wp-login.php?
    redirect_to=%2F%7Etooabsen%2Ftheherald%2Fwp-admin%2F

    Help?

  4. billtooabsent
    Member
    Posted 8 years ago #

    Update:

    I followed the directions for Changing the URL, here:
    http://codex.wordpress.org/Changing_The_Site_URL

    And the added step of deleting the wp_content_cache did the Trick.

    I'm now up and running at tooabsent.com/theherald

  5. ulyssesr
    Member
    Posted 8 years ago #

    Cool. The cache! I never had to do this with older versions of WordPress. I'll keep that in mind if I move WordPress in the future.

Topic Closed

This topic has been closed to new replies.

About this Topic