WordPress.org

Ready to get started?Download WordPress

Forums

ok simple question... (10 posts)

  1. Domi1975
    Member
    Posted 5 years ago #

    Hello all,

    One simple question :

    I have a WordPress site running on my localhost. Everything works just fine, it's my first website made with WordPress, and i'm thrilled by the numerous possibilities of WP.

    Now i want to upload the site with WS_FTP to my domain. So: how do i do that ? Yes, i know, you upload all your files under the map public_html, but i want to know what about my database ? If there is some CLEAR info about this subject, it's hard to find.

    D.

  2. Evita
    Member
    Posted 5 years ago #

    1. Install WordPress on your server (new installation).
    2. Local go to dashboard/manage/export - here you can create a export file (.xml) for your posts, pages, categories etc. and save it
    3. Public go to dashboard/manage/import - here you can import the created xml file

  3. Domi1975
    Member
    Posted 5 years ago #

    I have a mix of a new installed wordpress site and my site. I have certain links, certain images, but no slideshow etc... something isn't right here...

  4. Domi1975
    Member
    Posted 5 years ago #

    Ok, nobody ? I thought it was a simple question... -)

  5. Evita
    Member
    Posted 5 years ago #

    I have a mix of a new installed wordpress site and my site. I have certain links, certain images, but no slideshow etc...

    That is not very helpful.
    What did you?
    Any error messages?
    What works and what not?

  6. yaulia
    Member
    Posted 5 years ago #

    export-import with phpmyadmin
    - create new database in your webhosting
    - import
    - Setup wp-config
    - really2 simple

  7. Domi1975
    Member
    Posted 5 years ago #

    Yes really 2 simple... right.

    when i import the xml file, i get this (well i'm not going to copy the whole list here, but you'll get the idea..)

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing post Bath & Birth...

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing post About...

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing attachment http://localhost/wordpress/wp-content/uploads/2008/08/img_3366.jpg... Remote file error: Remote file returned error response 404
    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing post About...

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing attachment http://localhost/wordpress/wp-content/uploads/2008/08/img_33661.jpg... Remote file error: Remote file returned error response 404
    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing attachment http://localhost/wordpress/wp-content/uploads/2008/08/img_33662.jpg... Remote file error: Remote file returned error response 404
    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing attachment http://localhost/wordpress/wp-content/uploads/2008/08/img_33663.jpg... Remote file error: Remote file returned error response 404
    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing attachment http://localhost/wordpress/wp-content/uploads/2008/08/abouticon.jpg... Remote file error: Remote file returned error response 404
    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing post ...

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing post En... Start !...

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing post About...

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing post About...

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing post Contact...

    Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/bathandb/domains/bathandbirth.be/public_html/wp-admin/import/wordpress.php on line 343
    # Importing post Contact...

    So...
    i installed wp on the server
    i have a new database in my webhosting
    i did an export in localhost of the xml file
    i imported this file on wp on the server
    then i get that list

  8. houseofstrauss
    Member
    Posted 5 years ago #

    There is a further issue here: Importing an XML file is good for content like links, text categories, comments etc. The file is uploaded to your server and populates the wp tables from the uploaded data. Images are another matter. So when if you select import all media in the import option (orwhatever the phrase is) it has to query the addresses for your images and transfer them across to your new site.

    This can be a problem, if you have images on a 'localhost' server that is NOT configured to run publically. If you are importing images from another public server, this works ok, although sometimes, you have to repeat the import sequence, if you run out of memory. On the second run it usually picks up where it failed last time and continues to import the remaining images.

    I have a similar problem moving a domain from one server to another using the xml export/import method. Once I change the DNS to the new site, the old site image addresses cant be reached. My solution is to rename image addresses in my downloaded xml file changing the domain (that has now moved)to the old server temporary IP address. I'm hoping that using this xml file will import old images correctly.

    This is a tricky procedure ... would be nice to hear from someone who has done it successfully??

  9. Roy
    Member
    Posted 5 years ago #

    Make sure you choose the option import WordPress file (or whatever it is called). I've done it numerous times and have no idea what you are talking about :-)
    The export/import are with the same version of WP? It should be really that simple and contain each post, page, comment, etc.

  10. houseofstrauss
    Member
    Posted 5 years ago #

    Domi1975 a further thought here ... using an xml file will ONLY populate posts/categories/comments/dates/etc data. Any plugins and theme you install and configure locally is NOT part of and xml file import. If plugin and theme configurations are not important to you then go xml. If you want the whole site 'mirrored' on your server, you need to use a full wp-content local backup and transfer this to your online server version. Then you need to make a local database backup and overwrite this copy to your online server. Then, you will nearly have a mirror.

    I say nearly, because there are some very important extras that need to be done to make the online site work properly

    1- If you add any images locally to your site, you should not use full urls like http://localhost/mysite/wp-content/uploads...etc

    If you do this, these must be changed en mass to reflect the new address of the images online. You can do this by opening the local database and doing a msss search and replace of the URL The other option is to add images by releative URLs such as ./wp-content/etc ... If you do this the ./ will be filled in by whatever the site root is.

    2- permalinks. I doubt that you used permalinks (pretty links) locally, but if you did, change this back to default before backing up the DB

    3- Site URL this also needs changing in the database if it has been written as http://localhost/ ...

    4- save the database with these changes and save it as the same name as the database for the online version of the site.

    5- You should now be able to 'overwrite' the online database, by selecting to restore it in cpanel your new modified local version.

    6- Clear browser cache and cookies and login with your local login details.

    7- If you want to keep a synchronised copy of your site locally, try out this system here http://www.mariosalexandrou.com/blog/?p=233

    I have done this procedure a few times quite successfully, but you need to take time to check everything, especially the database changes. If you're not comfortable with hacking the database file, this can be daunting at first.

    Remember, everything in your localhost database that refers to http://localhost/ must be changed to show http://mydomain.com/ where 'mydomain' is your online TLD

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.